[mythtv-users] External channel change command not working (solved)

Don Brett dlbrett at zoominternet.net
Wed Dec 27 03:00:17 UTC 2017


On 12/26/2017 1:12 PM, Don Brett wrote:
> Command line parsing seems to work differently in 16.04.3 (worked in 
> 12.04).  Using the script here 
> "https://www.mythtv.org/wiki/LircChannelChanger", playback stops when 
> I change channels (no blaster/ no HDPVR activity).  I can run it from 
> a command prompt, but not in myth.  This works:
>
> don at nick:~$ /home/mythtv/LircChannelChanger 
> --cf=/home/mythtv/LircChannelChanger-Motorola --xmitter 2
> -Works fine
>
> Using only "/home/mythtv/LircChannelChanger" seems to work (tunes the 
> HDPVR, no blaster activity), but adding the config file makes it 
> stop.  Hitting escape gets me out of live-tv, so Mythfrontend's not 
> frozen.  Any suggestions on what to try?
>
> Don
>
>
> ---
> This email has been checked for viruses by Avast antivirus software.
> https://www.avast.com/antivirus
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

I tried  this script instead: 
https://www.mythtv.org/wiki/Change-channel-lirc.pl (no config file 
needed).  It also worked manually, but failed in Mythtv.  I changed the 
file name from change-channel-lirc.pl to change-channel-lirc-pl....that 
worked.  Does this qualify as a bug?

Don



More information about the mythtv-users mailing list