[mythtv-users] Need IR blaster help for HD-PVR

Don Brett dlbrett at zoominternet.net
Sun Dec 24 18:29:31 UTC 2017


On 12/23/2017 9:10 AM, Don Brett wrote:
> I have a new build of 16.04.3; mostly went well.  The remote control 
> and blaster uses the Window Media Center Transceivers (mce).   I 
> selected the remote control options during installation and the remote 
> works great.
>
> I went to  MythBuntu Control Centre and enabled the IR transmitter 
> with "USB-UIRT2 Motorola Cable box".  The remote stopped working and I 
> couldn't  exit Mythfrontend without killing it through a terminal 
> (killall mythfrontend / killall mythfrontend.real). Disabling the IR 
> transmitter put it back to  working,  but without a blaster.
>
> Any suggestions on what to try for the blaster?
> ---
> This email has been checked for viruses by Avast antivirus software.
> https://www.avast.com/antivirus
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org
I tried using MyBlaster instead of Lirc, but the script throws an error 
when configuring USB.  From searching, it used to work, but broke on an 
upgrade (not sure which).  Now, it fails on this line:

$termios->getattr($serial->fileno()) || die "getattr: $!\n";

, error message is:
getattr: Inappropriate ioctl for device

I'm not a Perl programmer; any suggestions on how to fix?

Don

PS: MyBlaster script is here:
https://sourceforge.net/projects/myblaster/files/MyBlaster.1.4.1/MyBlaster1.4.1.zip/



More information about the mythtv-users mailing list