[mythtv-users] Anyone record Comet network OTA?

John Pilkington J.Pilk at tesco.net
Wed Dec 13 10:14:23 UTC 2017

On 13/12/17 02:48, George Bingham wrote:
> Hello everyone,
>     I am dealing with some weirdness that I bet others may have seen and 
> figured out before....
>     One of the multiplexes here in Kansas City shows the "Comet" network 
> - and it is mostly old sci-fi movies and some shows. One of them is 
> Stargate Atlantis which I enjoy.
>      When I first started getting that network in my area, it showed 
> Stargate SG1, which I also enjoy and so I set them to record, and found 
> that the commercial detection didn't work very well and that when I 
> would go into edit mode it would be difficult to find good cut points 
> because there were a lot of "blank" frames in the recordings. And when I 
> would find a good cut point and then watch the edited version, the cuts 
> would be off, like 30 seconds into the commercial, and then resume 30 
> seconds after the ending cut point.
>       So I gave up running commercial detection on that channel by 
> calling it "commercial free" in the channel editor and would just skip 
> through the commercials as I watched. That was weird ttoo, because I'd 
> hit the forward key when the commercial started, and then go back ~30 or 
> 40 seconds before the beginning of the commercial....
>       Anyway, I finally figured out that if I "fix the seek table" on a 
> recording, that I could manually run a commercial edit and it would work 
> fine. That solved much of my problems with that channel. But then I 
> decided it would be nice to try to save an episode or two and that's 
> where I am having problems again.
>      I can make a flawless recording, and then do the initial lossless 
> transcode to get the commercials edited out, but after that there is a 
> lot of pixelation in the resulting file that wasn't there in the original.
>      I think what might be causing the problem is that possibly because 
> they've taken a 4:3 original show, reformatted it to fill a 16:9 hd 
> screen - without distorting the image, and also maybe because the show 
> has been formatted for streaming (the network is also streamed by their 
> website and things like roku boxes) there are some "blank" frames in 
> there that mess up even a lossless transcode.
>      Has anyone else run into this and figured out a way to get a decent 
> transcoded video? Since the pixellation is introduced in the "lossless" 
> mythtranscode step that honors the cutlist, any filters for ffmpeg won't 
> work - I don't think.
>      I routinely transcode and save other shows from other networks and 
> I have not run into this before, both HD content and SD. This network is 
> new and maybe they do things differently.
>      I am just using the default lossless mythtranscode command to get 
> rid of commercials and I am seeing the problems. Are there other options 
> for transcoding from a mythtv recording that honors the cutlist that I 
> can try?
>      If anyone is curious about seeing what I am running into - I can 
> supply copies of the recordings before and after the transcode to remove 
> commercials if that would help.
> Thanks for any insight or experience that you can share with me.

TTBOMK lossless mythtranscode is intended for mpeg2video, so I assume 
that is what your recordings are supposed to be.  Have you tried running 
mythtranscode -m *without* a cutlist first? After making a copy.

That might clean it up a bit.  It should change the file type from .ts 
to .mpg too, and rebuild the seektable for future manual editing. 
Alternatively a Project-X based tool might work, but involve more 

John P

More information about the mythtv-users mailing list