[mythtv-users] MythTV qtwebkit dependency

Tom Dexter digitalaudiorock at gmail.com
Sat Oct 29 10:01:04 UTC 2016


On Wed, Oct 26, 2016 at 5:24 AM, Paul Harrison <mythtv at sky.com> wrote:
> On 24/10/16 14:58, Tom Dexter wrote:
>
>> On Sun, Oct 23, 2016 at 12:49 PM, Paul Harrison <mythtv at sky.com> wrote:
>>>
>>> On 23/10/16 16:50, Tom Dexter wrote:
>>>
>>>> On Tue, Oct 11, 2016 at 5:19 PM, John P Poet <jppoet at gmail.com> wrote:
>>>>>
>>>>> qtwebkit is/was also being used to show program details (Hit 'I' with a
>>>>> recording selected).  In master the dependency on qtwebkit has been
>>>>> removed.
>>>>> I probably should back port that change to fixes/0.28.
>>>>>
>>>>> John
>>>>>
>>>> I was curious on one aspect of this: Looking at the current master, it
>>>> looks as though the configure script still has a hard requirement for
>>>> qtwebkit. Is there something I'm missing there?
>>>>
>>>> I'm also deciding as to whether to install 0.28 as it stands now or to
>>>> wait until when/if that dependency is removed. Any idea as if that
>>>> will be backported?
>>>>
>>>> Thanks!
>>>> Tom
>>>>
>>> We have a web browser widget that is used by the web browser and the RSS
>>> feed reader etc. that still uses the Qt Webkit stuff.
>>>
>>> Paul H.
>>>
>> I'm a little confused now. Is it in fact possible to compile without
>> gtwebkit? This seems to contradict John's original reply above.
>>
>> Tom
>>
>
> I think John forgot we still use Qt Webkit for the browser widget that is
> part of MythUI and is still being used by the plugins.
>
>
> Paul H.

Is that mythbrowser you're referring to? It's too bad this is
required, given that most users will never technically need it. Qt
Webkit is a big requirement the way it is, but the odd compile time
requirement for ruby (which I don't really understand) makes things
even worse.

Thanks for the reply.

Tom


More information about the mythtv-users mailing list