[mythtv-users] Upgrade failure / problem 0.17

Ken Bass kbass at kenbass.com
Sun Feb 27 20:01:47 UTC 2005

Ken Bass wrote:
> Hi all, I've upgraded last night to 0.17 but all is not well.
> I went from 0.15 to 0.17
> When I ran the backend it said it updated the schema fine.
> When I ran the frontend it had the following problem:
> 2005-02-26 23:34:11.984 Upgrading to schema version 1051
> 2005-02-26 23:34:12.040 DB Error (Performing database upgrade):
> Query was: ALTER TABLE recorded ADD COLUMN lastmodified TIMESTAMP NOT NULL;
> Error was: Driver error was [2/-1]:
> QMYSQL3: Unable to execute query
> Database error was:
> Duplicate column name 'lastmodified'
> new version: 1051
> 2005-02-26 23:34:12.040 Couldn't upgrade database to new schema, exiting.
> Following some archive advice for two other schema issues I did
> a ALTER TABLE recorder DROP COLUMN lastmodified;

  Just a followup - it looks like after doing the above, even though the 
schema was updated, it did not add back the lastmodified column. I'm 
missing the lastmodified column in my recorded database.

  Whats the proper and safe way to add this back?

More information about the mythtv-users mailing list