[mythtv] Did I find a bug? netcat 6546

Bill Meek keemllib at gmail.com
Fri Aug 21 04:12:44 UTC 2020

On 8/20/20 5:10 PM, faginbagin wrote:
> I tried to "query location" on a frontend and got a timeout. When I went to check on the frontend, it was paused and displaying the "Playback Menu". Query location worked as expected when I returned to the "Watch Recordings" screen and when I was playing or paused on a recording. But when I pressed M/Menu while playing or paused, I could reproduce the timeout. Is this a bug?

Can't say if it's a bug, but check the frontend log. The timeout
can be avoided with something like this:

$ echo "query location" | nc -i1 -q2 -w2 localhost 6546
MythFrontend Network Control
Type 'help' for usage information

2020-08-20 22:03:29.816381 W [7204/7204] CoreContext tv_play.cpp:4985 (ProcessNetworkControlCommand) - TV::ProcessNetworkControlCommand():
Ignoring network control command because dialog is waiting for a response


More information about the mythtv-dev mailing list