[mythtv] render2019 comments

Mark Kendall mark.kendall at gmail.com
Tue Oct 22 12:37:15 UTC 2019

On Tue, 22 Oct 2019 at 00:27, Tim Pletcher <pletchtd at gmail.com> wrote:
> I just gave the 2019-render branch (devel/2019-render v31-Pre-1095-gc7eabdaf86) a try on one of my frontend machines.  The frontend is home-built Apollo Lake Celeron J3455 system running Xubuntu 18.04 with Vaapi version 1.10. The frontend is used almost exclusively for viewing NTSC LiveTV and the output is configured for a 1920x1080 at 59.94 modeline.  The frontend is configured with a VAAPI2 profile with Vaapi acceleration and opengl-hw High quality deinterlacing.
> Everything works great with the exception of one issue:
> On 1920x1080i channels where deinterlacing is in use, any overlaid info flickers in the overlaid section in the top 1/4 or of the screen (see video here: https://youtu.be/PXospaUX1lo). The same flickering behavior is also observed if viewing a 1920x1080i at 30fps recording so this doesn't appear unique to LiveTV.  The overlay flickering is not present in any circumstance when viewing 1280x720 at 60 content where deinterlacing is not in use.
> To compare, I also tried the render branch on another machine with an Nvidia card (GT 1030 / driver version 390.116).  Using VDPAU acceleration and opengl-hw deinterlacing on this frontend, the overlay flickering is not present with either interlaced or progressive content.
> Any hints on why I might be experiencing this with VAAPI acceleration on my Apollo Lake machine?


Thanks for the video. Very helpful - though a curious issue.

This can only be a performance problem as the OSD is the last thing to
be displayed - certainly not a vsync problem as the video is fine. As
a sanity check can you possibly produce a log with "-v
playback,gpu,gpuvideo" logging.

Also worth going into the detail of the display profile page, if you
haven't done so already, and ensuring that you have everything setup
properly - as previously mentioned, the display profiles aren't
currently migrated completely. You'll need VAAPI acceleration then try
setting deinterlacers to high quality and enabling both shaders and
driver deints. If you still see the issue, try dropping the quality of
the deinterlacers.

Furthermore, again if you haven't tried it already, try to force EGL
from the command line - which gives much better VAAPI performance.
Something like:

QT_XCB_GL_INTEGRATION="xcb_egl"  mythfrontend -v playback

I'm not sure how powerful that GPU is or what features it supports -
so it may be falling back to some basic VAAPI deinterlacing or OpenGL
shaders. Logs would confirm - or alternatively if you try a different
theme (e.g. MythCentre-wide) it will show which deinterlacer is in use
in the Debug OSD screen.

All that said, on reflection I think this is an OpenGL flushing issue.
Flushing is currently disabled - I'll add it back by default. I'm
pretty sure that will fix the problem.

Thanks and regards

More information about the mythtv-dev mailing list