[mythtv] render2019 comments

Mike Bibbings mike.bibbings at gmail.com
Tue Oct 1 15:06:32 UTC 2019

On 29/09/2019 12:55, John Pilkington wrote:
> I briefly tried current render2019 789dda6 with Fedora29 x86_64 nvidia 
> GT_710 430.40, but have gone back to master.
> Primary reason is that mythcommflag --rebuild and mythpreviewgen both 
> 'Failed to initialise VAAPI connection' and quit.  My cutting script 
> uses these.
> Also panning shots in 1080p DVB-T2 recordings are as seen through 
> jelly, worse than in master.  DLNA does it best (although subtitle 
> sync seems broken there).  But I didn't try much fine-tuning.
> John P

I have tried 2019-render branch on a few different machines, accelerated 
playback works ok once I had setup new video profile.

Originally the frontends were running master branch with appropriate 
accelerated video profile.

Is it intended to automatically migrate old profiles to  new profiles or 
will Users have to reconfigure ?

I have tried on Intel Graphics : TV via HDMI 1920x1080 50Hz and laptop 
1366x768 @60HZ

Nvidia Graphics: laptop 1920x1080 @60Hz

AMD Ryzen 3 2200G with Radeon Vega Graphics: TV via HDMI 3840x2160 @50Hz 
and 60Hz

I can also try on Raspberry Pi models 2,3 and 4 if someone can give me 
the build incantations for OpenMax (Pi 2 Pi3) and Opengl vc4-fkms-v3d 
(pi4), including what other build depends are required (some mesa-dev 
libraries ?).

The only real problem I have is the UK Freeview DVB-T/T2 LiveTV channel 
switching issue (trac ticket https://code.mythtv.org/trac/ticket/13292)  
is now even worse in that it takes much longer to show failure.

Using any of my tuners: TBS6280 (dual tuner PCI-e) or SiliconDust HD 
HomeRun CONNECT QUATTRO (model HDHR5-4DT, firmware  20190621) or 
Hauppauge Quad HD (PCI-e)  or TBS 6522 (dual tuner PCI-e) or Astrometa 

I have put a few mythfrontend logs (-v playback,libav --loglevel debug) 
in my Dropbox 

The change  m_ic->max_analyze_duration = 60 * AV_TIME_BASE; has had some 
effect in that some channel changes are now "working" after 20 seconds 
or more, depending on channel rate.

I still see instances of the wrong codec being opened and the reopening 
failing (invalid argument). Also I see Probe size (5000000) being hit.

2019-10-01 13:46:56.032686 I [23348/23348] CoreContext 
decoders/avformatdecoder.cpp:2107 (ScanStreams) - AFD: Already opened 
codec not matching (MP2 vs MP2). Reopening
Looking at the code

avformatdecoder.cpp seems to have a error starting at if block at line 2102

         if (enc->codec && par->codec_id != enc->codec_id)
                 QString("Already opened codec not matching (%1 vs %2). 
             enc = gCodecMap->getCodecContext(m_ic->streams[strm]);

l2106 .arg(ff_codec_id_string(enc->codec_id))
l2107 .arg(ff_codec_id_string(enc->codec->id)));
both have the same codec, I suspect one of them should refer to 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-dev/attachments/20191001/c5e09c08/attachment.htm>

More information about the mythtv-dev mailing list