[mythtv] 2019-devel: lipsync drift

Mark Kendall mark.kendall at gmail.com
Tue Nov 26 10:49:24 UTC 2019


John

Is that the correct link? It's an android log...:)

On Tue, 26 Nov 2019 at 10:44, John Pilkington <johnpilk222 at gmail.com> wrote:
>
> On 26/11/2019 08:56, Mark Kendall wrote:
> > John
> >
> > Apologies for the delay - I've been away with the fairies for a few days:)
> >
> > Can you please post full logs for the working and non-working cases?
> > The snippets are useful but I need the 101 other pointers that the
> > logs might give.
> >
> > Given the nature of the problem, I'd suggest with  '-v playback,gpu
> > --loglevel=debug' logging.
> >
> > If you want to go 'hardcore' as well  then add timestamp and audio
> > options - though the logs will be fairly lengthy:)
> >
> > thanks and regards
> > Mark
> >
> > On Mon, 25 Nov 2019 at 23:57, John Pilkington <johnpilk222 at gmail.com> wrote:
> >>
> >> On 24/11/2019 22:41, John Pilkington wrote:
> >>> To continue...
> >>>
> >>> I have a 'new' F30 box, i3 4-core with nVidia and a single VGA-driven
> >>> monitor, again running c794391ad. The only recordings at present are
> >>> from assorted iptv channels, but they show no obvious a/v drift.
> >>>
> >>> The DispRes: Desktop video mode on frontend startup and the DispRes:
> >>> SwitchToGUI on exit are both clean 1920x1080 60.000 Hz
> >>
> >> I commented earlier on the size of the timing StdDev shown in the
> >> terminal log when the Playback Data OSD is active.  It was around 25 ms,
> >> with a frame interval of 40 ms.  The SD appears to track the correction
> >> increment set for AVSync2, which suggests that a correction is being
> >> applied on every frame.  I had 30 ms, and now have 2 ms.  There is still
> >> a drift, though.
> >>>
> >>> John
>
> The recording has been through my usual demux by Project-x and remux by
> mplex process, which has delivered good sync over seveal years.  It has
> speech to camera and shows the problem.
>
> AVSync2 2 ms, Standard decode, 2 cpus, OpenGL, HQ deinterlace, no ticks
>
> mythfrontend -v playback,gpu --loglevel=debug | tee lipsync.log
>
> https://drive.google.com/open?id=1llzEU9b37okqiiNSNvm-JCuOrKZCOKqD
>
> HTH
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-dev
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org


More information about the mythtv-dev mailing list