[mythtv] Android gdb woes

Peter Bennett pb.mythtv at gmail.com
Tue Mar 6 16:57:37 UTC 2018


Trying to debug on Android.

I am using the gdb.sh script with an NVidia shield.

If I run ./gdb.sh on my linux machien, then it displays a bunch of 
messages, and eventually gets to a (gdb) prompt. If I enter c 
(continue), MythTV launches on the Shield and I can debug it by using 
ctrl-c and using gdb commands.

However, sometimes, after entering c (continue), nothing happens. There 
is a message on the shield screen that it is waiting for the debugger to 
attach and a button that lets you cancel. It gets no further.

At first this happened about 1 time out of 4. I tried restarting the 
shield and other things and eventually it would work again.

Now this happens every time. Restarting the shield does not help, 
killing mythtv from adb does not help.

I can debug by starting MythTV from the shield and then connecting with 
./gdb.sh. If I do that I get a bunch of SIG33 errors in gdb and messages 
on the shield that the application has stopped responding. This is not 
ideal.

Any idea what I can do to get this to work?

Peter



More information about the mythtv-dev mailing list