[mythtv] extremly slow mythfilldatabase in 0.28

Paul Harrison mythtv at sky.com
Sat Jul 16 09:12:53 UTC 2016


On 16/07/16 07:46, Torbjorn Jansson wrote:
> On 2016-07-16 02:25, Roger Siddons wrote:
>> On 14/07/16 22:05, Torbjorn Jansson wrote:
>>>
>>> also when i moved to 0.28 a while back the mythtv-setup was also
>>> extremely slow at opening one of the settings screens.
>>> i think it was the input connections screen but dont remeber exactly.
>>> what seemed to happen was that mythtv-setup was trying to connect to
>>> each and every upnp enabled device on my local lan for no good reason.
>>>
>>> at first i thought something was wrong since there were no ui feeback,
>>> just a lockup then a few minutes later the settings screen opened.
>>>
>>
>> IIUC it's scanning for VBoxes (Virgin cable box).
>> It's been mentioned before but TTBOMK nothing has been done yet.
>>
>
> yes it did say vbox and i could not understand why it would try to 
> connect to upnp devices on the local lan.
> especially since i had not configured any vbox sources.
>

It's actually trying to discover any VBoxes which are DVB receiver IP 
streamers (https://www.mythtv.org/wiki/VBox)  which announce themselves 
on the network using upnp.

I've been sent another couple of demo boxes to try out so will be 
returning to the VBox support in the near future and will see if I can 
rework the auto discovery to not block for 3 seconds or whatever the 
delay is.

Paul H.




More information about the mythtv-dev mailing list