[mythtv] (fixed) Re: Master build failure after Fedora23 > 24

John Pilkington J.Pilk at tesco.net
Tue Dec 13 19:23:50 UTC 2016

On 08/12/16 21:07, John Pilkington wrote:
> On 08/12/16 12:30, John Pilkington wrote:
>> On 06/12/16 22:52, John Pilkington wrote:
>>> On 06/12/16 18:46, John Pilkington wrote:
>>>> On 06/12/16 13:37, Richard Shaw wrote:
>>>>> Also as a data point my packages on RPM Fusion are not having any
>>>>> problems on any release of Fedora, though it's on fixes/0.28, not
>>>>> master.
>>>>> Thanks,
>>>>> Richard
>>>> Stuart, Richard:  Thanks for your replies.  I haven't been able to
>>>> investigate today but will do so asap.  I came across other non-myth
>>>> posts with the same error that seemed to point to interference from
>>>> other references to /usr/include, and my log is full of those.  The
>>>> specfile was based on one of Richard's for 0.28 with a few tweaks, so
>>>> I'll re-examine his latest for clues - and perhaps see if I can build
>>>> again for SL7, on which I'm currently running 0.29pre189
>>>> John
>>> As another data point, on the fc24 box,
>>> [john at HP_Fed SPECS]$ mock -r fedora-24-x86_64-rpmfusion_free --buildsrpm
>>> --spec mythtvmaster29pre229p#12901mock.spec --sources=../SOURCES
>>> followed by
>>> [john at HP_Fed SRPMS]$  mock -r SL-7-x86_64  --rebuild
>>> mythtv-master-0.29.229.s.fc24.src.rpm
>>> has created a full set of el7 packages - with the audiograph patch from
>>> #12901, which seems more benign than most of my later attempts.  But I
>>> haven't installed them yet on the production box.  Reported rebuild time
>>> was 53 min.
>> Running ansible installed nothing new, and I have tried both with and
>> without Richard's patch of 16 April on the legacy-encumbered
>> INCLUDEPATH, which probably affected only the plugins.
>> I still haven't been able to build rpms for fc24, but running
>> ./configure and make in the 'mock' directory left behind,
>> /var/lib/mock/fedora-24-x86_64/root/builddir/build/BUILD/mythtv-master/mythtv
>> seems to have succeeded.  I did it as 'john' and suspect that it won't
>> have used the clean 'mock' environment, but that probably isn't a
>> problem.  I don't know how safe (file locations etc) it will be to
>> install when I have previously run (in fc23) an rpm-based version.  Any
>> guidance appreciated.
> I took the plunge and did 'sudo make install'   After setting up
> shared-library access and building plugins, operations seem to be back
> to normal - but I have never used and haven't tested autostarting
> features or many of the plugins.  Thanks to Peter Bennett et al for the
> 'Build from Source' wiki.

I'm now again able to build rpms for master, and have a working FE/BE 
F24 box based on them.  I started from Richard's 0.28-10 specfile and 
have made only minor changes to use the downloaded tarball in which the 
top directory is 'mythtv-master'. These make dnf see it as a downgrade 
from 0.28.  The only patches are for the audiograph display, where my 
'improvements' are still not doing what I hoped.

Switching away from the non-rpm build above meant that I had to revert 
the shared-library path change, and I have removed the stated dependency 
on mythweb.  I removed that on ffmpeg too, but then found that 
MythArchive needs mjpegtools which brought it back.

I haven't tried a rebuild for SL7 yet because of the current breakage of 
DVD playback.

Thanks to all concerned.

 >> John P

More information about the mythtv-dev mailing list