[mythtv] Latest trunk segfault in mythfrontend - Fedora 19

Tom Lichti tom at redpepperracing.com
Wed Mar 5 14:15:50 UTC 2014

On Wed, Mar 5, 2014 at 8:36 AM, Tom Lichti <tom at redpepperracing.com> wrote:

> On Tue, Mar 4, 2014 at 6:35 PM, Paul Harrison <mythtv at sky.com> wrote:
>> On 04/03/14 23:18, Tom Lichti wrote:
>>> Hello all,
>>> I updated my frontend to latest trunk on the weekend, and that worked
>>> fine. Last night I noticed my Fedora install was woefully out of date so I
>>> ran a yum update. After the reboot, mythfrontend crashes at startup. I had
>>> previously updated the NVidia driver, as the old one would not compile with
>>> the new kernel, then I did a complete recompile of mythtv on the box, and
>>> it still crashes. I recompiled with debug enabled, the backtrace is here:
>>> http://pastebin.ca/2651625
>>> Unfortunately there were about 400 packages updated, so I doubt I'm
>>> going to be able to track down which one is causing the crash, if it's even
>>> related (pretty sure it is though), I'll try rebooting into the old kernel
>>> and see if that works, but if anyone sees anything in the backtrace, I'd
>>> love to hear opinions.
>>> Thanks
>>> Tom
>> It's a bug in the 334.xx nvidia drivers.
>> https://devtalk.nvidia.com/default/topic/691399/-334-16-
>> crash-in-libglesv2-with-glgenbuffers-/
>> I think the only solution at the moment is to downgrade the drivers.
> Perfect. I had rebooted into the previous kernel and previous 3.25 driver
> and it worked, so I wasn't sure if it was the kernel or the driver. I'll
> try a previous driver with the new kernel and see where that gets me.
> Thanks!
> Tom

And that seemed to do it, I installed 3.31 of the NVidia drivers and it
works. Now to figure out why LIRC keeps shutting down...

Thanks again.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-dev/attachments/20140305/0824c9c7/attachment.html>

More information about the mythtv-dev mailing list