[mythtv] Cannot connect to the mythzmserver

Paul Harrison mythtv at sky.com
Sun Dec 21 14:40:35 UTC 2014

On 21/12/14 14:01, John Pilkington wrote:
> On 21/12/14 10:10, Paul Harrison wrote:
>> On 20/12/14 23:56, John Pilkington wrote:
>>> On 20/12/14 22:18, Paul Harrison wrote:
>>>> I think you are confusing the UI Theme from the Menu Theme they are 
>>>> two
>>>> different things. One defines the look and layout of the screens 
>>>> and the
>>>> other defines the layout of the main menus. By default Myth ships with
>>>> DVR, Classic, Default and Media Center Menu Theme menu themes. 
>>>> Other UI
>>>> themes can also add there own Menu theme if they want.
>>>> If you look in the Appearance settings what is the 'Menu Theme' set 
>>>> to?
>>>> Paul H.
>>> You're probably right...  I'm confused.  Qt, Default, 1024, 576, 64,
>>> 64, Use GUI size, Use border, Use fixed window size.
>>> 2442 now building on Santa's box.  A new build of 2441 had the same
>>> popup.
>> So you are using the Default menu theme.
>> You will still have to clear the IP or set the port to -1 to suppress
>> the popup.
>> You should find the MZM  settings under Setup->Info Centre
>> Settings->ZoneMinder Settings.
>> If they are not there then you have got something screwed up somewhere.
>> Check your version of info_settings.xml matches this one :-
>> https://github.com/MythTV/mythtv/blob/master/mythtv/themes/defaultmenu/info_settings.xml 
> Yes, OK
>> Assuming your install prefix is '/use/share' You will find it in
>> /usr/share/mythtv/themes/defaultmenu/
>> Also check the plugin exists and is named correctly in
>> /usr/lib/mythtv/plugins/
>> It should be called libmythzoneminder.so
> See below
>> Paul H.
> After a few problems in edit, build and install on the other box. I 
> now have one installation from 8 Dec (2422) and one from today (2442)
> In the new one I get *two* warning popups with big red crosses when a 
> menu screen is displayed; one is steady, one flashes.  The FE log 
> shows that it's repeatedly trying to connect, with no address defined 
> for host: localhost.  Tries at 1 sec intervals continue indefinitely, 
> although the popups are hidden during playback.
> I do, however, now have a ZM Settings entry.  Changing the IP 
> (originally, I've tried localhost, and ::1:) 
> and/or port (originally 6548, tried -1) has no effect on the popups, 
> and the log still shows 'Failure to connect to (::1:6548) Connection 
> refused.'  This doesn't suggest to me that it hasn't found a missing ZM.
> The plugin (both boxes) is at
> /usr/lib64/mythtv/plugins/libmythzoneminder.so
> with all the other libXX.so plugins - and I know mytharchive gets 
> found :-)
> Thanks,
> John

OK I can't reproduce it here both setting the ip to blank and setting 
the port to -1 disable connecting to the server altogether but I'm 
running a slightly modified version of MZM though so I must of missed a 
change somewhere.

Paul H.

More information about the mythtv-dev mailing list