[mythtv] Cannot connect to the mythzmserver

John Pilkington J.Pilk at tesco.net
Sat Dec 20 19:18:44 UTC 2014


On 20/12/14 18:27, Paul Harrison wrote:
> On 20/12/14 12:51, John Pilkington wrote:
>> With my recent 0.28-pre-2422 build (8 Dec) I'm getting a popup about
>> this when starting the frontend.  I don't use zm and haven't found
>> anywhere to make zm-specific settings.  An attempt to uninstall
>> mythzoneminder wanted to remove all of myth.
>>
>> I don't think I saw the popup with my previous build from 7 Nov.
>>
>> I can dismiss it with no apparent badness, but it's not user-friendly.
>> Comments?
>>
>> Thanks,
>>
>> John P
>>
>
> MythZoneMinder has always put up a popup when it fails to connect.
>
> What is new though is it now starts a thread when the FE starts up to
> monitor for status changes from ZM so it can show a popup miniplayer
> when an alarm is signalled. Looks like this has caused an unexpected
> problem for users with MythZoneminder installed but no mythzmserver
> running to connect to.
>
> I'll change it so it only tries to connect if a server and port are
> defined in the MythZoneMinder settings. It will mean you will have to
> change the  'IP address of the MythZoneMinder server' setting to blank
> and/or the 'Port the server runs on'  to -1 on the MythZoneMider
> settings page to suppress the popup.
>
> Paul H.

OK, Paul.  Thanks for the explanation - but, as I said, I don't 
recollect seeing any mention of ZM on any Myth or mythtvsetup screen. 
Previously I only knew it was there because the mythzoneminder plugin 
rpm package was installed - and the packages as built won't allow its 
'normal' removal :-)

John



More information about the mythtv-dev mailing list