[mythtv] tuner troubleshooting

Jason Hiller jasonchiller at yahoo.com
Mon Jul 8 01:12:23 UTC 2013

On 7/7/2013 3:46 PM, Jason Hiller wrote:
> Hi Jason,
> On 7/6/2013 8:07 PM, Jason Hiller wrote:
>  > I am having trouble with mythtv recognizing my Hauppauge HVR-1600 card.  Myth setup fails to probe my card but everything I have found in my system logs indicates the OS sees the card and it is functioning.  I opened a ticket for this but thought I would try to help it along by doing some troubleshooting.
>  >
>  > I downloaded the code and got it compiled.  Now I was hoping someone could point me in the direction of the code that probes for the tuner cards.  Like the library, files, etc.
>  >
>  > Or if anybody has experience with this issue that would be great too.  Thanks.
> I've CCed the mythtv-users list, since I think you might get more feedback from other users with HVR-1600 cards.
> FWIW, I've got a slave backend working with two HVR-1600 cards. I'm only using the digital feature at the moment, but there was a time when I had configured the analog side too. I've got the cards working on a 32 bit system that multi boots the following operating system/mythtv combinations:
> mythbuntu 10.10/ mythtv 0.23-fixes
> mythbuntu 12.04/ mythtv 0.26-fixes
> The 10.10/0.23-fixes combination is my production environment. I'm working on upgrading to 12.04/0.26-fixes, but I'm not there yet. I have recorded a handful of shows with both cards on 0.26-fixes, so I know they work with that version of mythtv and with a 32 bit linux kernel 3.2.
> What linux distro are you using and what version of mythtv?
> HTH,
> Helen
> Thanks for the response Helen.  I actually posted to mythtv-users first but didn't get any responses that solved my problem.  That led me to myth development.  I am running Ubuntu 12.04.2 64bit and 0.26 of mythtv.  Like I said I believe the OS see the cards.  I pasted below some entries from dmesg that seems to indicate all is well.  I also read somewhere to run the command 'cat /dev/video0 > test.mpg' and if the file that comes back is a valid video file all is well in the OS.  I tried this and the test.mpg was valid.

/dev/video0 is used to record from the analog side of the HVR-1600. Is that what you tried to configure in mythtv? Or was it the digital half of the card. I think the patch Gary wrote about is for the digital half of the card.

> [    2.221174] cx18:  Start initialization, version 1.5.1
> [    2.221193] cx18-0: Initializing card 0
> [    2.221195] cx18-0: Autodetected Hauppauge card
> [    2.221229] cx18 0000:05:01.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
> [    2.221240] cx18-0: Unreasonably low latency timer, setting to 64 (was 32)
> [    2.240488] cx18-0: cx23418 revision 01010000 (B)
> [    2.503149] cx18-0: Autodetected Hauppauge HVR-1600
> [    2.503150] cx18-0: Simultaneous Digital and Analog TV capture supported
> [    2.626048] cs5345 17-004c: chip found @ 0x98 (cx18 i2c driver #0-0)
> [    2.635931] cx18-0: Registered device video0 for encoder MPEG (64 x 32.00 kB)
> [    2.635934] DVB: registering new adapter (cx18)
> [    2.710088] cx18-0: DVB Frontend registered
> [    2.710091] cx18-0: Registered DVB adapter0 for TS (32 x 32.00 kB)
> [    2.710130] cx18-0: Registered device video32 for encoder YUV (20 x 101.25 kB)
> [    2.710165] cx18-0: Registered device vbi0 for encoder VBI (20 x 51984 bytes)
> [    2.710189] cx18-0: Registered device video24 for encoder PCM audio (256 x 4.00 kB)
> [    2.710191] cx18-0: Initialized card: Hauppauge HVR-1600
> [    2.710218] cx18:  End initialization
> [    2.711482] cx18-alsa: module loading...
> [    2.925644] cx18-0: loaded v4l-cx23418-cpu.fw firmware (158332 bytes)
> [    3.160259] cx18-0: loaded v4l-cx23418-apu.fw firmware V00120000 (141200 bytes)
> [  3.166612] cx18-0: FW version: (Release 2007/03/12)
> [    4.259701] cx18-0 843: loaded v4l-cx23418-dig.fw firmware (16382 bytes)
> [    4.302961] cx18-0 843: verified load of v4l-cx23418-dig.fw firmware (16382 bytes)

Nothing jumps out at me as being a problem from the dmesg output.

Here's how I've configured the digital half of my HVR-1600s in mythtv-setup's "Capture Card Setup" screens:
Card type: DVB-T/S/C, ATSC or ISDB-T tuner card
DVB device: /dev/dvb/adapter0/frontend0
Frontend ID: Samsung S5H1409 QAM/Subtype: ATSC
Signal timeout (ms): 500
Tuning timeout (ms): 3000
Under Recording Options:
Max recordings: 1
X Wait for SEQ start header.
X Open DVB card on demand
n Use DVB card for active EIT scan (unchecked because I use Schedules Direct for program data)
DVB tuning delay (ms): 0

If I wanted to set up the analog side, here's what I would use:
Card type: Analog to MPEG-2 encoder card (PVR-150/250 /350, etc.)
Video device: /dev/video0
    Note, "/dev/video0" has to be typed in for the HVR-1600, it won't be prepopulated for you.
VBI device: <blank>
Probed info: Hauppauge HVR-1600 [cx18]
Tuning timeout (ms): 12000


Thanks for the suggestion Helen but neither worked.  When I setup the digital half I see the error "Could not get card info for card /dev/dvb/adapter0/frontend0 Subtype: Unknown error".  And when I setup the analog side I see "Failed to open" in the Probed info section.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-dev/attachments/20130707/8db527b9/attachment.html>

More information about the mythtv-dev mailing list