[mythtv] What is an "episode" ? What is a "part" ?

Stuart Morgan stuart at tase.co.uk
Mon Nov 19 14:47:40 UTC 2012

On Monday 19 Nov 2012 09:36:59 Daniel Thor Kristjansson wrote:
> On 11/16/2012 08:01 AM, Håkon Alstadheim wrote:
> > I find I confuse myself more on this question the more I think about
> > this. I get shows with descriptions like "(2:3)" , "(2:3/s4)" or
> > "(2/s4)". I've also seen "Sesong 4. (2) ", indicating episode 2, total
> > number of episodes 3, and season 4 in those examples. Other variations
> > also exist. This system is fairly new in my part of the world, so I have
> > never seen how "part 2 of episode2" would be marked.
> > 
> > My question is: should I use the above strings from the description to
> > fill in "syndicatedepisodenumber" AND also partnumber and parttotal ?
> > Why is one a string and the others integers ?
> > What would it take to change myth into storing episodes, parts, seasons
> > and total episodes in a consistent way? -- That is, how is this
> > information used by myth ?
> The partnumber and parttotal are the
> episode number and number of episodes in a series and is
> intended to inform algorithms needing to know that info.

My understanding was that it was specifically for multi-part episodes sharing 
the same episode ID/subtitle, so that the scheduler would record both parts 
instead of treating the second as a duplicate?

There's unquestionably a lot of confusion around these three columns and there 
always has been. At the very least I'd back dropping syndicatedepisodenumber 
in favour of discrete episode #, series # fields (these already exist but are 
currently reserved for metadata grabber supplied values). Renaming the part* 
columns with more descriptive names would also be good. Either episode #, 
total_episodes OR episode_part, episode_totalparts depending on what the 
intention is here.
Stuart Morgan

More information about the mythtv-dev mailing list