[mythtv] HELP: CentOS 6.3 install "MYTH_PROTO_VERSION was empty."

Richard Shaw hobbes1069 at gmail.com
Sat Dec 8 23:11:58 UTC 2012

I "upgraded" my combined FE/BE from Fedora 14 to CentOS 6.3 today and
I'm running into the following issue:

2012-12-08 17:07:44.033219 C  Protocol version check failure.
			The response to MYTH_PROTO_VERSION was empty.
			This happens when the backend is too busy to respond,
			or has deadlocked due to bugs or hardware failure.

Also, mythweb gives me the "Can't connect to"
message even though the backend is running.

I've got specified in both places in mythtv-setup (but
still have ::1 for the ipv6 which I'm not using).

I can't find ANY errors in the backend log. Everything seems fine.
SELinux is disabled and I've tried with the same result with iptables

I even tried backing down to 0.25.2 with the same result...


Obligatory system info:
# mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version : 0.26.0-3.el6 (v0.26.0-55-g09ac5b2)
MythTV Branch : fixes/0.26
Network Protocol : 75
Library API : 0.26.20120822-1
QT Version : 4.6.2
Options compiled in:
 linux release use_hidesyms using_alsa using_jack using_oss
using_pulse using_pulseoutput using_backend using_bindings_perl
using_bindings_python using_bindings_php using_dvb using_firewire
using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv
using_ivtv using_joystick_menu using_libcrypto using_libdns_sd
using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg
using_opengl_video using_qtwebkit using_qtscript using_qtdbus
using_v4l2 using_v4l1 using_x11 using_xrandr using_xv
using_bindings_perl using_bindings_python using_bindings_php
using_mythtranscode using_opengl using_vaapi using_vdpau
using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

More information about the mythtv-dev mailing list