[mythtv-commits] Ticket #13121: Sat>IP client support

MythTV noreply at mythtv.org
Wed Feb 17 11:04:17 UTC 2021


#13121: Sat>IP client support
--------------------------------+-------------------------------
 Reporter:  cg@…                |          Owner:  Klaas de Waal
     Type:  Patch - Feature     |         Status:  assigned
 Priority:  minor               |      Milestone:  32.0
Component:  MythTV - Recording  |        Version:  Master Head
 Severity:  low                 |     Resolution:
 Keywords:                      |  Ticket locked:  0
--------------------------------+-------------------------------

Comment (by fe31nz):

 I have been recording SAT>IP with MythTV for several years now by manually
 putting URLs into the database using IPTV (FREEBOX) tuners as per
 https://www.mythtv.org/wiki/SAT2IP_players_as_capture_cards.

 It is good to see real SAT>IP support arriving for v32, and I thought I
 had better test it to make sure it was going to work for me.  I have set
 up a new PC using the old motherboard from my mother's MythTV box, put
 Xubuntu 20.04 on it and installed v32 from the PPA.

 For my current production system I am using minisatip on the same box as
 my main MythTV system, which has a TBS6909 8 tuner DVB-S2 card and a
 TBS6209 8 tuner DVB-T2 card.  Mythbackend directly uses 5 of the TBS6209
 DVB-T2 tuners for the 5 DVB-T muxes available here in New Zealand, and my
 MHEG5 EPG gathering uses one more of the DVB-T2 tuners, leaving two DVB-T2
 tuners for minisatip.  One of the TBS6909 DVB-S2 tuners is used for OpenTV
 format EPG gathering and the other 7 DVB-S2 tuners are used by minisatip.
 Minisatip uses my Sky NZ satellite card to decrypt my pay TV channels via
 Oscam.  My mother's MythTV box also connects to minisatip to record Sky NZ
 channels.

 On the new test PC, I created two sources, one for DVB-T and one for
 DVB-S2.  I created two SAT>IP tuners, one for each source, and tried
 channel scanning.  Scanning on the DVB-T tuner worked fine and I was able
 to record from the channels it put in the database.  However, when I try
 to scan using the DVB-S2 tuner, I immediately get a popup error message
 "Error parsing parameters".  I used Wireshark to check for traffic to
 minisatip, and the error was occurring before any packets were sent.  I
 tried a number of different combinations of scan settings to see if that
 would help, but I got the same error each time.  Then I deleted all
 sources and tuners and started again with only one source for DVB-S2 and
 one DVB-S2 SAT>IP tuner.  But I got exactly the same error message.

 MythTV Version : v32.0~master.202102151820.e787645fd9~ubuntu20.04.1
 MythTV Branch : master
 Network Protocol : 91
 Library API : 32.20200101-1
 QT Version : 5.12.8
 Options compiled in:
  linux profile use_hidesyms using_alsa using_oss using_pulse
 using_pulseoutput using_backend using_bindings_perl using_bindings_python
 using_bindings_php using_dvb using_firewire using_frontend using_hdhomerun
 using_satip using_vbox using_ceton using_hdpvr using_ivtv
 using_joystick_menu using_libcec using_libcrypto using_gnutls
 using_libdns_sd using_libfftw3 using_libxml2 using_lirc using_mheg
 using_opengl using_egl using_qtwebkit using_qtscript using_qtdbus
 using_taglib using_v4l2 using_v4l2prime using_x11 using_libbluray_external
 using_profiletype using_systemd_notify using_systemd_journal using_drm
 using_bindings_perl using_bindings_python using_bindings_php
 using_freetype2 using_mythtranscode using_opengl using_egl using_drm
 using_vaapi using_nvdec using_vdpau using_ffmpeg_threads using_mheg
 using_libass using_libxml2 using_libmp3lame

 Klaas: If it is any use for your testing, I should be able to make my
 minisatip available for Internet connections - but that would require that
 connections came from static IP addresses that I could whitelist in my
 router.  Leaving completely open ports to minisatip would not be a good
 idea.  I have a fibre connection with 1 Gbit/s downstream and 500 Mbit/s
 upstream and my ISP's international bandwidth is good.

-- 
Ticket URL: <https://code.mythtv.org/trac/ticket/13121#comment:60>
MythTV <http://www.mythtv.org>
MythTV Media Center


More information about the mythtv-commits mailing list