[mythtv-commits] Ticket #13218: Problems decoding some H264 tansport streams

MythTV noreply at mythtv.org
Fri Feb 9 20:28:46 UTC 2018


#13218: Problems decoding some H264 tansport streams
----------------------------------+-----------------------------
 Reporter:  dag@…                 |          Owner:  pbennett
     Type:  Bug Report - General  |         Status:  accepted
 Priority:  major                 |      Milestone:  30.0
Component:  3rd Party - FFMPEG    |        Version:  Unspecified
 Severity:  medium                |     Resolution:
 Keywords:  decoding error        |  Ticket locked:  0
----------------------------------+-----------------------------
Changes (by pbennett):

 * status:  new => accepted
 * milestone:  needs_triage => 30.0


Comment:

 My testing shows that it works with the latest V29, which is V29.1, but
 not if using vaapi. It fails in V30-pre (master).

 There is a change of resolution detected in the file and the code to
 handle that is not working in v30-pre. I will work on fixing this.

 Note that the vaapi code currently cannot handle changes in resolution so
 this will fail in all versions if you have vaapi selected. Instead of
 vaapi select one of the opengl profiles if you have changes of resolution
 in your recordings.

 I do not see the "unknown decoding error" messages. When it fails with
 vaapi I see a different message. When it fails on V30 I see a segmentation
 fault.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/13218#comment:9>
MythTV <http://www.mythtv.org>
MythTV Media Center


More information about the mythtv-commits mailing list