<div dir="ltr"><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Tue, Jun 29, 2021 at 5:52 PM David Newman <<a href="mailto:dnewman@networktest.com">dnewman@networktest.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On 6/28/21 7:02 PM, James Linder wrote:<br>
<br>
> <br>
> <br>
>> On 29 Jun 2021, at 7:08 am, David Newman <<a href="mailto:dnewman@networktest.com" target="_blank">dnewman@networktest.com</a>> wrote:<br>
>><br>
>> Ever since upgrading from Ubuntu 16 LTS (and then 18 and now 20), I've<br>
>> been having an issue with an older Apple bluetooth keyboard where the<br>
>> keyboard becomes nonresponsive after somewhere between 2 and 10 minutes.<br>
>><br>
>> I can get it working again but only if I power-cycle the keyboard or<br>
>> remove/reinsert the dongle, or both. I've also tried fresh akaline AA<br>
>> batteries in the keyboard multiple times, and replacing the dongle, but<br>
>> the problem follows the keyboard.<br>
>><br>
>> The 'hcitool con' command shows the keyboard is still connected when<br>
>> this happens, usually in "state 1". However, the keyboard's caps lock<br>
>> key won't illuminate after it goes to sleep.<br>
>><br>
>> Is there some command on the Ubuntu side that would keep the keyboard<br>
>> awake? It's a pain to use as is.<br>
>><br>
>> Thanks!<br>
>><br>
>> dn<br>
>><br>
>><br>
>> Ubuntu 20.04.2 LTS (GNU/Linux 5.4.0-77-generic x86_64)<br>
>><br>
>> Apple magic keyboard (aluminum, early 2010s)<br>
>><br>
>> TrendNet TBW-106UB USB 2.0 dongle)<br>
> <br>
> Using mine on a NUC (builtin bluetooth) I have no issues (On ubuntu 20.04 and SuSE Leap 15.2)<br>
> James<br>
> <br>
> PS<br>
> My kbd is 2010ish<br>
<br>
Thanks. On further investigation, I think this could be due to some<br>
issue with the Myth box, either hardware or software, and not the Apple<br>
keyboard.<br>
<br>
1. A different Bluetooth keyboard, a brand-new Logitech K380, had the<br>
same issue of losing link soon after pairing with the Myth box.<br>
<br>
2. The Apple keyboard paired and maintained link with an iPad Pro, even<br>
after being idle for more than one hour.<br>
<br>
Both tests point back to some possible issue with the Myth box.<br>
<br>
Thanks in advance for any troubleshooting clues on keeping the Bluetooth<br>
link alive.<br>
<br></blockquote><div><br></div><div><div style="font-family:monospace,monospace" class="gmail_default">You might try adding:</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">usbcore.autosuspend=-1</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">to your kernel config.</div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
dn<br>
<br>
<br>
<br>
<br>
_______________________________________________<br>
mythtv-users mailing list<br>
<a href="mailto:mythtv-users@mythtv.org" target="_blank">mythtv-users@mythtv.org</a><br>
<a href="http://lists.mythtv.org/mailman/listinfo/mythtv-users" rel="noreferrer" target="_blank">http://lists.mythtv.org/mailman/listinfo/mythtv-users</a><br>
<a href="http://wiki.mythtv.org/Mailing_List_etiquette" rel="noreferrer" target="_blank">http://wiki.mythtv.org/Mailing_List_etiquette</a><br>
MythTV Forums: <a href="https://forum.mythtv.org" rel="noreferrer" target="_blank">https://forum.mythtv.org</a><br>
</blockquote></div></div>