<div dir="ltr"><div>I made some more progress setting up my new XMLTV grabber.  I think I have my config file and my database set up.  Mythfilldatabase is still not working.  When I run I get this back, I get this back now:</div><div><br></div><div>mythtv@Linux-Desktop:~/.xmltv$ mythfilldatabase<br>2021-07-10 12:52:30.978515 C  mythfilldatabase version: fixes/31 [v31.0-v31.0] <a href="http://www.mythtv.org">www.mythtv.org</a><br>2021-07-10 12:52:30.978527 C  Qt version: compile: 5.12.5, runtime: 5.12.8<br>2021-07-10 12:52:30.978725 I  Ubuntu 20.04.2 LTS (x86_64)<br>2021-07-10 12:52:30.978730 N  Enabled verbose msgs:  general<br>2021-07-10 12:52:30.978740 N  Setting Log Level to LOG_INFO<br>2021-07-10 12:52:30.991912 I  Added logging to the console<br>2021-07-10 12:52:30.992199 I  Setup Interrupt handler<br>2021-07-10 12:52:30.992205 I  Setup Terminated handler<br>2021-07-10 12:52:30.992211 I  Setup Segmentation fault handler<br>2021-07-10 12:52:30.992215 I  Setup Aborted handler<br>2021-07-10 12:52:30.992219 I  Setup Bus error handler<br>2021-07-10 12:52:30.992225 I  Setup Floating point exception handler<br>2021-07-10 12:52:30.992229 I  Setup Illegal instruction handler<br>2021-07-10 12:52:30.992236 I  Setup Real-time signal 0 handler<br>2021-07-10 12:52:30.992240 I  Setup Hangup handler<br>2021-07-10 12:52:30.992316 N  Using runtime prefix = /usr<br>2021-07-10 12:52:30.992319 N  Using configuration directory = /home/mythtv/.mythtv<br>2021-07-10 12:52:30.992344 I  Assumed character encoding: en_US.UTF-8<br>2021-07-10 12:52:30.992788 I  Empty LocalHostName. This is typical.<br>2021-07-10 12:52:30.992795 I  Using a profile name of: 'Linux-Desktop' (Usually the same as this host's name.)<br>2021-07-10 12:52:30.992837 I  Start up testing connections. DB localhost, BE , attempt 0, status dbAwake, Delay: 2000<br>2021-07-10 12:52:32.007731 N  Setting QT default locale to en_US<br>2021-07-10 12:52:32.007740 I  Current locale en_US<br>2021-07-10 12:52:32.007951 N  Reading locale defaults from /usr/share/mythtv//locales/en_us.xml<br>2021-07-10 12:52:32.021271 I  PowerDBus: Added UPower.Device '/org/freedesktop/UPower/devices/mouse_hidpp_battery_2'<br>2021-07-10 12:52:32.021454 I  Power: On AC power<br>2021-07-10 12:52:32.033397 I  Power: Supported actions: Suspend,Restart,Shutdown<br>2021-07-10 12:52:32.034224 I  Loading en_us translation for module mythfrontend<br>2021-07-10 12:52:32.035030 I  Current MythTV Schema Version (DBSchemaVer): 1361<br>2021-07-10 12:52:32.036627 I  MythCoreContext::ConnectCommandSocket(): Connecting to backend server: <a href="http://127.0.0.1:6543">127.0.0.1:6543</a> (try 1 of 1)<br>2021-07-10 12:52:32.038216 I  MythCoreContext::CheckProtoVersion(): Using protocol version 91 BuzzOff<br></div><div>2021-07-10 12:52:32.038374 I  Opening blocking connection to master backend</div>2021-07-10 12:52:32.081147 I  Updating source #1 (SD) with grabber tv_grab_zz_sdjson_sqlite<br>2021-07-10 12:52:32.082219 I  Found 279 channels for source 1 which use grabber<br>2021-07-10 12:52:32.082461 I  Starting IO manager (read)<br>2021-07-10 12:52:32.082449 I  Starting process signal handler<br>2021-07-10 12:52:32.083229 I  Starting IO manager (write)<br>2021-07-10 12:52:32.083385 I  Starting process manager<br>2021-07-10 12:52:32.683420 I  Grabber has capabilities: baseline manualconfig preferredmethod lineups apiconfig <br>2021-07-10 12:52:33.338342 I  Grabber prefers method: allatonce<br>2021-07-10 12:52:33.338855 I  XMLTV config file is: /home/mythtv/.mythtv/SD.xmltv<br>2021-07-10 12:52:34.051189 E  FillData: XMLTV grabber returned error code 1<br>2021-07-10 12:52:34.400985 E  Error in 1:1: unexpected end of file<br>2021-07-10 12:52:34.430104 I  Cardutil: HDHomeRun Cablecard Present.<br>2021-07-10 12:52:34.449013 I  Cardutil: HDHomeRun Cablecard Present.<br>2021-07-10 12:52:34.467689 I  Cardutil: HDHomeRun Cablecard Present.<br>2021-07-10 12:52:34.468362 I  No programs found in data.<br>2021-07-10 12:52:34.509654 E  Failed to fetch some program info<br>2021-07-10 12:52:34.509679 I  Adjusting program database end times.<br>2021-07-10 12:52:34.551841 I      0 replacements made<br>2021-07-10 12:52:34.551846 I  Marking generic episodes.<br>2021-07-10 12:52:34.593770 I      Found 0<br>2021-07-10 12:52:34.593776 I  Extending non-unique programids with multiple parts.<br>2021-07-10 12:52:34.635569 I      Found 0<br>2021-07-10 12:52:34.635574 I  Fixing missing original airdates.<br>2021-07-10 12:52:34.718546 I      Found 0 with programids<br>2021-07-10 12:52:34.801869 I      Found 0 without programids<br>2021-07-10 12:52:34.801874 I  Marking repeats.<br>2021-07-10 12:52:34.802978 I      Found 0<br>2021-07-10 12:52:34.802982 I  Unmarking new episode rebroadcast repeats.<br>2021-07-10 12:52:34.803122 I      Found 0<br>2021-07-10 12:52:34.844810 I  Marking episode first showings.<br>2021-07-10 12:52:35.014316 I      Found 0<br>2021-07-10 12:52:35.014326 I  Marking episode last showings.<br>2021-07-10 12:52:35.190043 I      Found 0<br>2021-07-10 12:52:35.234908 I  <br>===============================================================<br>| Attempting to contact the master backend for rescheduling.  |<br>| If the master is not running, rescheduling will happen when |<br>| the master backend is restarted.                            |<br>===============================================================<br>2021-07-10 12:52:35.235438 N  mythfilldatabase run complete.<br>2021-07-10 12:52:35.235493 I  PowerDBus: Closing interfaces<br>2021-07-10 12:52:35.236767 I  Waiting for threads to exit.<br><div>2021-07-10 12:52:35.236989 I  Exiting</div><div><br></div><div>Does anyone have any idea what is wrong?</div><div><br></div><div>Lloyd<br></div></div>