<div dir="ltr">On Sun, Jan 13, 2019 at 2:17 PM David Engel <<a href="mailto:david@istwok.net">david@istwok.net</a>> wrote:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On Sun, Jan 13, 2019 at 06:59:13AM -0700, Greg Oliver wrote:<br>
> I was on vacation last week and got home to a very close to full disk.<br>
> This morning I examined some stuff and deleted a lot of stuff, but it is<br>
> actually not deleting anything when it says it is ::<br>
> [...]<br>
> I have deleted over 500 recordings from this Shield and modified the<br>
> property from 1GB free to 100GB free in settings, yet the system remains at<br>
> 3.99GB free no matter what I do.<br>
> <br>
> Long ago (the original frontend I used on the backend had the setting to<br>
> immediately delete files and do not delete slowly.<br>
> <br>
> I have many many TB of disk since I use my systems for work and I never<br>
> want mythtv managing my disk space - when I delete it - I want it gone<br>
> immediately (well, the current 5 minute delay is OK) - I will never have<br>
> issues with disk speeds when doing deletes.<br>
> <br>
> Anyone know how to fix this and get it to behave like the old frontend.<br>
> Here are my settings from the DB with this regard ::<br>
<br>
Deleted recordings are moved to the Deleted group.  They stay there<br>
for some amount of time (default of 1 day, minimum of 5-20 minutes,<br>
controllable by the DeletedMaxAge setting) before being deleted unless<br>
they are auto-expired or manually deleted from that group.  This<br>
behavior is to satisfy the people who want the ability to "undelete"<br>
recordings and also to avoid the "can't delete right now/the file is<br>
busy" issue for most users.  If you want recordings deleted ASAP,<br>
delete them normally, then switch to the Deleted group and delete them<br>
again.<br>
<br>
David<br>
-- <br>
David Engel<br>
<a href="mailto:david@istwok.net" target="_blank">david@istwok.net</a><br></blockquote><div><br></div><div style="font-family:monospace,monospace" class="gmail_default">I originally deleted them all in the Normal Watch Recordings screen.  I then changed my filter to Deleted and use the "Add to Playlist" option like I always have and then "Playlist -> Delete Playlist".  The disappeared from the GUI (and I did that for LiveTV as well since I watched the Cowboy game live last night), but no space freed.</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">I waited 30 minutes or so and then tried to restart the backend.  This was early - no TVs were watching anything, but it would not restart through normal methods and systemd ended up killing it and it left a defunct process.  I went ahead and rebooted the machine after I I stopped all of my esxi hosts.</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">Whewn it came back up, it deleted stuff up to the 100GB change I made in settings, but I *did not* go back and try all the previous stuff of deletion since I have never had this issue before.</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">If what I tried should normally work, cool - if not, did I miss a step - I have never had to do this with my old frontend - just started with the Shield.  I would have used the frontend / backend box, but I unplugged the mceusb receiver and bt receivers a while ago and probably tossed them somewhere it would take a while to find :)</div><div style="font-family:monospace,monospace" class="gmail_default"><br></div><div style="font-family:monospace,monospace" class="gmail_default">Thanks!<br></div></div></div>