<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr">On Fri, Jan 11, 2019 at 8:37 AM Kris J <<a href="mailto:kris.jensen.knj@gmail.com">kris.jensen.knj@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><br><br>
> <br>
>     Many thanks Peter<br>
> <br>
> <br>
> I think I track it down to DB corruption.<br>
> Running ( mysql -umythtv -p mythconverg -e 'status;' ) on my server shows:<br>
> --------------<br>
> mysql  Ver 14.14 Distrib 5.7.24, for Linux (x86_64) using  EditLine wrapper<br>
> <br>
> Connection id:          11854<br>
> Current database:       mythconverg<br>
> Current user:           mythtv@localhost<br>
> SSL:                    Not in use<br>
> Current pager:          stdout<br>
> Using outfile:          ''<br>
> Using delimiter:        ;<br>
> Server version:         5.7.24-0ubuntu0.16.04.1 (Ubuntu)<br>
> Protocol version:       10<br>
> Connection:             Localhost via UNIX socket<br>
> Server characterset:    latin1<br>
> Db     characterset:    utf8<br>
> Client characterset:    utf8<br>
> Conn.  characterset:    utf8<br>
> UNIX socket:            /var/run/mysqld/mysqld.sock<br>
> Uptime:                 4 hours 2 min 39 sec<br>
> <br>
> Threads: 46  Questions: 2801872  Slow queries: 0  Opens: 4221  Flush <br>
> tables: 1  Open tables: 128  Queries per second avg: 192.449<br>
> --------------<br>
> <br>
> Searching for answers lead me to a old outdated wiki page that explains <br>
> the problem and how to fix the DB.<br>
> (<a href="https://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding" rel="noreferrer" target="_blank">https://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding</a>)<br>
> <br>
> However I'm leery to apply the suggested fix as the page has been <br>
> labeled outdated.<br>
> <br>
> Is the "Fixing the database corruption" entry still a viable fix for <br>
> Mythtv .29.1?<br>
<br>
I ran the same mysql status query on my Fedora 28 box running master, <br>
which connects and runs well with a firestick 4K and Peter's 32-bit <br>
20181124 build.  The characterset results are identical.  I have a <br>
'Server:  MariaDB' line, and the Server Version is 10.2.19-MariaDB <br>
MariaDB Server. Using outfile: has two ticks, not the double-tick as <br>
shown in your post, and my UNIX socket is /var/lib/mysql/mysql.sock, <br>
where the differences might be Fedora/Ubuntu or just a quirk of my setup.<br>
<br>
I don't claim to understand mysql, but I'm not certain that your mysql <br>
config is bad.<br>
<br>
John P<br>
<br>
<br><br></blockquote><div><br></div><div><br></div><div>Thank you Paul and John..(Hmm. 1/2 of a good music band)  :)</div><div><br></div><div>I went google around for some of the error messages I am seeing. I am sure one of the pages sent me off on a tangent that I found ether relevant or interesting. </div><div><br></div><div>Thanks for the reassurance.</div><div><br></div><div>Kris.</div></div></div>
</blockquote></div></div>