<br><div class="gmail_quote">On Wed, Jul 14, 2010 at 6:00 PM, James Orr <span dir="ltr">&lt;<a href="mailto:james.orr7@gmail.com">james.orr7@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<br><div class="gmail_quote"><div><div></div><div class="h5">On Wed, Jul 14, 2010 at 3:06 PM, James Orr <span dir="ltr">&lt;<a href="mailto:james.orr7@gmail.com" target="_blank">james.orr7@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0pt 0pt 0pt 0.8ex;border-left:1px solid rgb(204, 204, 204);padding-left:1ex">
<div class="gmail_quote"><div><br>Getting worse ... now a power cycle does not fix it.  In fact now it&#39;s crashing the backend. <br><br>2010-07-14 14:54:46.157 ProgramInfo(): Updated pathname &#39;&#39;:&#39;&#39; -&gt; &#39;1195_20100714145445.mpg&#39;<br>


2010-07-14 14:54:46.179 ProgramInfo(): Updated pathname &#39;&#39;:&#39;&#39; -&gt; &#39;1195_20100714145445.mpg&#39;<br>2010-07-14 14:54:52.080 DevRdB(/dev/video0) Error: Poll giving up<br>2010-07-14 14:54:52.085 MPEGRec(/dev/video0) Error: Device error detected<br>


2010-07-14 14:54:52.086 DevRdB(/dev/video0): Stop(): Not running.<br>2010-07-14 14:54:52.670 RingBuf(/mnt/be1hd1/1195_20100714145445.mpg): Invalid file (fd -1) when opening &#39;/mnt/be1hd1/1195_20100714145445.mpg&#39;.<br>


2010-07-14 14:54:52.719 ProgramInfo(): Updated pathname &#39;&#39;:&#39;&#39; -&gt; &#39;1195_20100714145445.mpg&#39;<br>2010-07-14 14:54:52.790 ProgramInfo(): Updated pathname &#39;&#39;:&#39;&#39; -&gt; &#39;1195_20100714145445.mpg&#39;<br>


2010-07-14 14:54:52.815 RingBuf(/mnt/be1hd1/1195_20100714145445.mpg) Error: Invalid file descriptor in &#39;safe_read()&#39;<br>2010-07-14 14:54:53.006 RingBuf(/mnt/be1hd1/1195_20100714145445.mpg) Error: Invalid file descriptor in &#39;safe_read()&#39;<br>


2010-07-14 14:54:53.206 RingBuf(/mnt/be1hd1/1195_20100714145445.mpg) Error: Invalid file descriptor in &#39;safe_read()&#39;<br>2010-07-14 14:54:53.406 RingBuf(/mnt/be1hd1/1195_20100714145445.mpg) Error: Invalid file descriptor in &#39;safe_read()&#39;<br>


<br>That&#39;s repeated a lot until ...<br><br>2010-07-14 14:55:09.130 ProgramInfo(): Updated pathname &#39;&#39;:&#39;&#39; -&gt; &#39;1195_20100714145445.mpg&#39;<br>2010-07-14 14:55:09.131 TVRec(25): Changing from WatchingLiveTV to None<br>


2010-07-14 14:55:09.134 ProgramInfo(1195_20100714145445.mpg), Error: Unknown type, recording width was 0<br>*** glibc detected *** /usr/bin/mythbackend: malloc(): memory corruption: 0x08459881 ***<br>======= Backtrace: =========<br>


/lib/libc.so.6[0xb468bfd4]<br>/lib/libc.so.6[0xb468e555]<br>/lib/libc.so.6(__libc_malloc+0x96)[0xb4690136]<br>/usr/lib/qt4/libQtCore.so.4(_Z7qMallocj+0x1d)[0xb49e23bd]<br>/usr/lib/qt4/libQtCore.so.4(_ZN10QByteArrayC1Eic+0x36)[0xb49ea426]<br>


/usr/lib/qt4/libQtCore.so.4(_Z15qt_error_stringi+0x59)[0xb49dfd09]<br>/usr/lib/qt4/libQtCore.so.4[0xb49e6ecf]<br>/usr/lib/qt4/libQtCore.so.4[0xb49e704b]<br>/usr/lib/qt4/libQtCore.so.4(_ZN6QMutex4lockEv+0xf5)[0xb49e2855]<br>


/usr/lib/libmythtv-0.23.so.0(_ZN16DeviceReadBuffer15fill_ringbufferEv+0x2c)[0xb74e7fbc]<br>/lib/libc.so.6(clone+0x5e)[0xb46ee9de]<br>======= Memory map: ========<br>08048000-081aa000 r-xp 00000000 03:03 4014102    /usr/bin/mythbackend<br>


081aa000-081ab000 r--p 00161000 03:03 4014102    /usr/bin/mythbackend<br><br><br>Help!<br><br></div></div></blockquote></div></div><div>After I turn the HD-PVR off then on again I am able to successfully cat /dev/video0 &gt; tmp.mpg.<br>

<br>The HD-PVR lights up, I get a recording.<br><br>When I try to watch live TV through myth I get the above errors (except it seems to have stopped crashing since I rebooted, but still get the first part), the HD PVR doesn&#39;t light up, 0 byte recording.  If I then try to cat into a file again the HD PVR does not light up and I get a 0 byte file.<br>

<br>After turning it off/on again I can cat to a file as much as I want, but as soon as myth tries it all blows up.<br><br>Will upgrading to the newer firmware help? I&#39;m on 0x12.<br><br>My mythtv install is from the gentoo ebuild 0.23 p25073.  This is the most recent available through portage.<br>
</div></div></blockquote><div><br></div><div>I pulled out one of my memory sticks and it seems to be working OK for now. </div></div><br>