<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#330099">
<font face="Arial">Hi!<br>
<br>
A little story about my media center project with linux using
Ubuntu/Mythbuntu (&gt;=8,04) for better understand.<br>
<br>
I have a <u>TV Card  ASUS My Cinema P7131</u>, which have the common <u>chip
Saa713x</u> aside the old btt chip at Portuguese market.<br>
The <u>graphic display card</u> is the very new <u>ASUS EAH3600 HD</u>,
which has <u>ATI chip</u>.<br>
<br>
With this two items I had image display drivers issues, some apps
didn't work. Desktop gaphics effects didn't work or crash. <br>
Showing TV was not acceptable since image at mythtv was doubled (see
image) and sound wrong sampled. Only mplayer with some setings
available on regular posts related to saa713x was able to do it fine.<br>
<br>
Nevertheless I found posts with more then one year old and some
suggestions not acceptable for some one need the thinks working with
less of less tricks or workarounds. Like launching marginal processes
like sox, auplay, etc etc.<br>
<br>
So this mail is my contribution to clear some old and unappropriated
suggestions since linux is getting better.<br>
<br>
To be quick I'll not provide fine grain details, but I think enough to
help any one who gets into same situation.<br>
<br>
So, first, <u>this HD graphics card works better with ATI manufacturer
driver for linux.</u> <u>These guys are updating very well.</u> So,
usually posts suggested to use the XOrg or even envy driver... between
this two, yes, the XOrg was better, but mythtv stand not working. ATI
manufacturer driver has been the best.<br>
For compiz you may turn off all performance and graphics improvements
with the ati control center app. I did this test prior install mythtv,
but remember to read that compiz and mythtv are not good friends.<br>
<br>
This TVCard model has a good thing, provides internally an audio wire
cdrom connection like, but I insisted on using DMA sound.<br>
In my case DMA sound device is /dev/dsp2, as you may read at TVCad box
or manual the sound is 32KHz, but saa7134_alsa module insists to config
44KHz as you may see on boot up messages.<br>
So, my battle was to do on app layer the setting for 32KHz. Mplayer
worked like this, reason why I tested freevo mean while with success.
But come back to mythtv, seamed to me that Mythtv had some features
that I may need, and freevo doesn't have them. But I liked the freevo's
philosophy.<br>
<br>
So, the solutions using mythtv:<br>
* for imaging is setting for Playback filter to the Default decoder
plus xlib has renderer (ffmpeg-&gt;xlib), and linear blend for
interlace issue. The oder options or gave to me wrong color or even
worst, doubled view.<br>
* for sound, regarding some log errors that were not totally
understandable to me, at Setup&gt;TV&gt;Recording Profiles&gt;Software
Encoders change codec to Uncompres and Sampling to 32KHz.<br>
<br>
For audio some posts sugested to go back using oss or sox or something
like it, but I think linux is going into the battle front, not to back
;-).<br>
<br>
By the way, the help given to me by posts related to thread
"[mythtv-users] Doubled screen - Is this any interlace issue?" were
important.<br>
<br>
</font><font face="Arial">Thanks to you all!<br>
Tomás<br>
</font>
<div class="moz-signature">-- <br>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
<title>José Tomás &lt;a class="moz-txt-link-rfc2396E"
href=&lt;a class="moz-txt-link-rfc2396E"
href=<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">"mailto:jtomas@totalstor.com"</a>&gt;<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">"mailto:jtomas@totalstor.com"</a>&lt;/a&gt;&gt;&lt;a
class="moz-txt-link-rfc2396E"
href=<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">"mailto:jtomas@totalstor.com"</a>&gt;<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">&lt;jtomas@totalstor.com&gt;</a>&lt;/a&gt;&lt;/a&gt;</title>
</div>
<div class="moz-signature">
<title>José Tomás &lt;a class="moz-txt-link-rfc2396E"
href=<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">"mailto:jtomas@totalstor.com"</a>&gt;<a class="moz-txt-link-rfc2396E" href="mailto:jtomas@totalstor.com">&lt;jtomas@totalstor.com&gt;</a>&lt;/a&gt;</title>
<table border="0" cellpadding="0" cellspacing="0">
  <tbody>
    <tr>
      <td
 style="font-size: 7pt; color: rgb(51, 102, 255); font-family: Tahoma;">
      <b><font color="navy" face="Arial" size="1"><span
 style="font-size: 8pt; font-family: Arial; color: navy; font-weight: bold;">José
Tomás</span></font></b><br>
      <hr height="1px" align="left" width="325"> <span
 style="font-size: 8pt; font-family: &quot;Comic Sans MS&quot;; color: navy; font-weight: bold;">Chico.mine.nu</span><br>
      <span
 style="font-size: 12pt; font-family: &quot;Comic Sans MS&quot;; color: rgb(51, 102, 255); font-weight: bold;"><a
 class="moz-txt-link-freetext" href="http://chico.mine.nu/">http://chico.mine.nu/</a>
      </span><br>
      <span
 style="font-size: 7pt; color: rgb(51, 102, 255); font-family: Tahoma;"> MSN:
      <a class="moz-txt-link-abbreviated" href="mailto:jfht@netc.pt">jfht@netc.pt</a><br>
 Skype: jfhtomas<br>
      </span>
      <hr height="1px" align="left" width="325"> </td>
    </tr>
  </tbody>
</table>
</div>
<br>
<div class="moz-signature"><br>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
<title>José Tomás &lt;jtomas@totalstor.</title>
<br>
</div>
</body>
</html>