[mythtv-users] MythTV and Wayland

John Pilkington johnpilk222 at gmail.com
Mon Mar 25 11:05:10 UTC 2024


On 24/03/2024 19:56, James Abernathy wrote:
> 
> 
> On Sun, Mar 24, 2024, 9:16 AM John Pilkington <johnpilk222 at gmail.com 
> <mailto:johnpilk222 at gmail.com>> wrote:
> 
>     I just did a quick search on this without finding much.
> 
>     For years I have been running mythtv master in Fedora KDE X11 with a
>     cheapo nvidia GT 710 card, mainly to get an HDMI output, using the
>     rpmfusion build of the closed-source 470xx driver.  That driver will
>     lose support later this year and its latest version is not yet
>     available
>     in rpmfusion.
> 
>     A few weeks ago after a kde update I started getting usually-brief
>     pauses with notifications of graphics resets in Kwin, and the
>     kde-fedora
>     list suggested switching to the reverse-engineered nouveau driver, with
>     the possibility that this might also work with Wayland, the 'coming
>     thing'.
> 
>     I now have MythTV master running with nouveau in the Plasma-X11
>     environment, although I haven't yet tried using VDPAU acceleration or
>     deinterlace;  it works and suits my use case.
> 
>     But Wayland isn't as good.  mythfrontend says VDPAU isn't available,
>     the menu screens show ghosting, the HDMI TV screen needs a new login
>     after it times out or is power cycled, and the (deprecated)
>     mythtv-setup
>     crashes on exit.
> 
>     I'm not sure whether these are 'known unknowns' or just unknown.  Are
>     they worth an 'issue' ?
> 
>     John P
> 
> 
>     _____________
> 
> 
> On my front ends running Wayland I run mythfrontend --platform xcb
> 
> Jim A

Thanks Jim, that could be useful.  I just tried the inverse.

from konsole under Plasma-X11.  None of the wayland options were found.
{{{

[john at HPFed ~]$ mythfrontend  --platform wayland
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" 
even though it was found.
This application failed to start because no Qt platform plugin could be 
initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, 
offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, 
wayland-xcomposite-glx, xcb.

Aborted (core dumped)


[john at HPFed ~]$ mythfrontend
2024-03-25 10:45:13.240403 I  Display: Requesting EGL for vendor 'Mesa 
Project, 1.5'
2024-03-25 10:45:13.424655 I  Setup Interrupt handler
2024-03-25 10:45:13.424663 I  Setup Terminated handler
2024-03-25 10:45:13.424670 I  Setup Segmentation fault handler
2024-03-25 10:45:13.424677 I  Setup Aborted handler
2024-03-25 10:45:13.424683 I  Setup Floating point exception handler
2024-03-25 10:45:13.424690 I  Setup Illegal instruction handler
2024-03-25 10:45:13.424697 I  Setup Bus error handler
2024-03-25 10:45:13.424705 I  Setup Real-time signal 0 handler
2024-03-25 10:45:13.424711 I  Setup Hangup handler
2024-03-25 10:45:13.424719 I  Setup User defined signal 1 handler
2024-03-25 10:45:13.424725 I  Setup User defined signal 2 handler
2024-03-25 10:45:13.424888 C  mythfrontend version: HEAD 
[v35-Pre-895109dd63] www.mythtv.org
2024-03-25 10:45:13.424892 C  Qt version: compile: 5.15.12, runtime: 5.15.12
2024-03-25 10:45:13.424917 I  Fedora Linux 38 (Thirty Eight) (x86_64)

}}}




More information about the mythtv-users mailing list