[mythtv-users] Raspberry Pi 5

James Linder jameslinder0 at gmail.com
Sun Mar 3 07:16:33 UTC 2024


On Fri, Mar 1, 2024 at 5:59 AM James Linder <jam at tigger.ws> wrote:
> 
>> I want to use a Pi5 as a backend.
>> One of the backend’s tasks is to do some logging, using a Qt5 program I wrote. Compile fails with
>> usr/include/c++/12/bits/stl_relops.:62: Parse error at “std"
>> 
>> Googling suggest bookworm-thats-wot-dunnit
> 
> Sounds like QT Bug 73263:
>   https://bugreports.qt.io/browse/QTBUG-73263
> which is actually a moc bug.
> 
> A common fix is to move the
>   #include <filesystem>
> to below the
>  #include <QApplication>
> or some other <Qsomething>
> include such as <QObject>
> 
>> The wiki on building from src urges not using ubuntu, as far as I can tell that relates to frontend stuff.
> 
> I suspect that at the time that that
> recommendation was written the
> graphics support for the Pi in
> Ubuntu was not optimal (so FE
> stuff).  Reportedly the performance
> got better (and then worse, and
> then better again) at various times
> in the Ubuntu release cycles.
> 
If anyone can guide me I’d appreciate it lots

Despite suggestions from Gary I made no progress
So I flashed the ubuntu image
*everything worked
but building, with a fan heatsink, had CPU temperature over 80C and throttling. Monitoring build on raspberryan I did not see over 63C. On idle the case runs HOT
So I tried to build on RockPi 5.
ansible hangs forever
I thought to install prebuilt. I’ve never used PPA but followed the wiki (https://www.mythtv.org/wiki/Installing_MythTV_on_Ubuntu)

jam at dvrHD:~$ sudo add-apt-repository ppa:mythbuntu/34.0
[sudo] password for root:
ERROR: ppa 'mythbuntu/34.0' not found (use --login if private)

jam at dvrHD:~$ cat /etc/os-release
PRETTY_NAME="Armbian 23.8.3 jammy"
NAME="Ubuntu"
VERSION_ID="22.04"
VERSION="22.04.3 LTS (Jammy Jellyfish)"
VERSION_CODENAME=jammy
ID=ubuntu
ID_LIKE=debian
HOME_URL="https://www.armbian.com"
SUPPORT_URL="https://forum.armbian.com"
BUG_REPORT_URL="https://www.armbian.com/bugs"
PRIVACY_POLICY_URL="https://www.armbian.com"
UBUNTU_CODENAME=jammy
ARMBIAN_PRETTY_NAME="Armbian 23.8.3 jammy”

[For the eagle eyed I do not like sudo as the user]

Before I nuke Armbian …
James



More information about the mythtv-users mailing list