[mythtv-users] season and episode population from schedules direct json has been incomplete.

Mike Perkins mikep at randomtraveller.org.uk
Sat Jan 13 16:24:40 UTC 2024


On 13/01/2024 15:34, Jay Harbeston wrote:
> 
> 
>> On Jan 12, 2024, at 4:22 PM, Jay Harbeston <jharbestonus at gmail.com> wrote:
>>
>>
>>
>>> On Jan 12, 2024, at 4:15 PM, Jay Harbeston <jharbestonus at gmail.com> wrote:
>>>
>>> As the subject indicates, I am seeing empty season episode information for many shows that should have it in mythtv.
>>>
>>> I did get a sampling of data from SD that showed S/E info in their data, that wasn’t making it into Mythtv.
>>>
>>> Any ideas!?
>>>
>>> What kind of data would I need to help trouble shoot?
>>> Thanks!
>>
>>
>> I forgot to mention version. I am running:
>>
>> Please attach all output as a file in bug reports.
>> MythTV Version : v34.0~master.202312062250.f6c7551148~ubuntu22.04.1
>> MythTV Branch : master
>> Network Protocol : 91
>> Library API : 34.20220913-1
>> QT Version : 5.15.3
>> Options compiled in:
>> linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_firewire using_frontend using_hdhomerun using_satip using_vbox using_ceton using_joystick_menu using_libcec using_libcrypto using_gnutls using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl using_egl using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_v4l2prime using_x11 using_system_libbluray using_system_libudfread using_systemd_notify using_systemd_journal using_drm using_bindings_perl using_bindings_python using_bindings_php using_freetype2 using_mythtranscode using_opengl using_egl using_drm using_vaapi using_nvdec using_vdpau using_ffmpeg_threads using_mheg using_libass using_libxml2 using_libmp3lame
>>
>>
> 
> So I have captured the xml file generated during the mythfilldatabase run, and searching through the file I don’t find any references to <season> or <episode> tags in it at all.
> 
> I am using  tv_grab_zz_sdjson as the grabber for schedules direct, and I am not seeing any errors during process.
> 
> I am using the xmltv package for ubuntu 22.04 v 1.1.1. with the tv_grab_zz_sdjson version 1.1.1 as well.
> 
> I do notice one thing in the xml file and that is that the program tags are programme instead of program.
> 
> Strange, Help!
> 
> Regards!
> 
I can't help more but I noticed the same thing beginning recently... maybe at the start of the new 
year? Series which I know have had series/episode info for years are suddenly blank. This also means 
that the scheduler doesn't pick anything much up and I have to eyeball them all (using mythweb) to 
make sure I'm not missing anything.

I'm running v33.1 from deb-multimedia so I doubt it's something mythtv related. Maybe a change 
within xmltv coding?

-- 

Mike Perkins




More information about the mythtv-users mailing list