[mythtv-users] Recordings Start and End Early

Barry Martin barry3martin at gmail.com
Thu Feb 22 17:56:24 UTC 2024


Ken:

>> I find that many of my program recordings start a bit before the
>> program, either at the end of what ever program was on the channel
>> before it, or in the network commercials in between. With the run time
>> set by the schedule to the standard 30/60 minutes, that clips the end of
>> the final scene of the program I am recording.
>>
>> When I remember, I add an extra minute to the rule. But am I missing
>> some global setting? The backend server is well synced to the time
>> standard.
> If you go to Recording Rules, there's a Default Template. Add a minute on
> both ends there and new recording rules will have it. I think you still
> need to update pre-existing rules.

 From personal experience, yes to both of Ian's answers.   The problem 
is not with your Backend times but the networks (I am assuming you are 
also in the U.S.).  I've noted one network is always on time, another is 
about 10 seconds fast and another about 30 seconds slow.  Played with 
Kaffeine recently to record a news segment and found it displayed the 
show times with seconds: "18:00:12"!  So the news was set to start 
twelve seconds later than I figured!




>
>>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:<http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240221/638277fe/attachment-0001.htm>
>
> ------------------------------
>
> Message: 4
> Date: Thu, 22 Feb 2024 08:20:45 +0100
> From: Klaas de Waal<klaas.de.waal at gmail.com>
> To: Discussion about MythTV<mythtv-users at mythtv.org>
> Subject: Re: [mythtv-users] Mythfrontend irrecoverable recorder error
> Message-ID:
> 	<CANcAQaM5H1vTAKvCDO2XX1Wu2ihF1jTAePkvx5CfAzt_d-d3=w at mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
> On Wed, 21 Feb 2024 at 23:46, Phill Edwards<philledwards at gmail.com>  wrote:
>
>> Hi, I recently had to swap out my HDHomerun 4x tuner to a HD Homerun 2x
>> tuner. I rescanned all the channels and set them up in Channel Editor and
>> most channels are OK. But when I try to live watch TV Channel 7 or Channel
>> 71 (Sydney, Australia) it pauses and then crashes out back to the menu with
>> a message saying "Irrecoverable recorder error". I see this in the
>> myuthbackend.log file:
>>
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E HDHRStreamHandler
>> recorders/hdhrstreamhandler.cpp:241 (UpdateFilters) HDHRSH[29](123048B3):
>> UpdateFilters called in wrong tune mode
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
>> tv_rec.cpp:3662 (TuningFrequency) TVRec[29]: TuningFrequency
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E TVRecEvent
>> recorders/hdhrstreamhandler.cpp:484 (TunerSet) HDHRSH[29](123048B3):
>> DeviceSet(vchannel 5): ERROR: invalid virtual channel
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E TVRecEvent
>> tv_rec.cpp:3735 (TuningFrequency) TVRec[29]: Failed to set channel to 71.
>> Reverting to kState_None
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
>> tv_rec.cpp:1057 (HandleStateChange) TVRec[29]: Changing from WatchingLiveTV
>> to None
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: N RecThread
>> recorders/recorderbase.cpp:490 (FinishRecording) Finished Recording:
>> Container: MPEG2-TS Video Codec: mpeg2video (720x576 A/R: 3 25fps) Audio
>> Codec: mp2
>> Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
>> tv_rec.cpp:826 (FinishedRecording) TVRec[29]:
>> FinishedRecording(10091_2024-02-21T22:37:15Z) damaged
>> recq:<RecordingQuality overall_score="0" key="10091_2024-02-21T22:37:15Z"
>> continuity_error_count="78" packet_count="34786">#012    <Gap
>> start="2024-02-21T22:00:00Z" end="2024-02-21T22:37:15Z" duration="2235"
>> />#012    <Gap start="2024-02-21T22:37:37Z" end="2024-02-22T00:30:00Z"
>> duration="6742" />#012</RecordingQuality>
>> Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I
>> MythSocketThread(49) mainserver.cpp:7858 (connectionClosed) Playback
>> sock(555c5f940440) 'MBE4' disconnected
>> Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I ProcessRequest
>> mainserver.cpp:1768 (HandleAnnounce) MainServer: MainServer::ANN Playback
>> Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I ProcessRequest
>> mainserver.cpp:1770 (HandleAnnounce) MainServer: adding: MBE4(555c5f9078f0)
>> as a client (events: 0)
>> Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I
>> MythSocketThread(37) mainserver.cpp:7858 (connectionClosed) Playback
>> sock(555c5f9078f0) 'MBE4' disconnected
>>
>> I see an error in there "ERROR: invalid virtual channel" but don't
>> understand why it doesn't like Channel 7 and what I can do to fix it.
>>
>> BTW I can watch those channels in the HDHomerun mobile app.
>>
>> Any suggestions?
>>
>> Regards,
>> Phill
>>
>> You can try "Delete All Capture cards" then create the new capture cards
> and connect them to the video source.
>
> Groetjes,
> Klaas.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:<http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240222/929fa3f5/attachment-0001.htm>
>
> ------------------------------
>
> Message: 5
> Date: Thu, 22 Feb 2024 19:37:59 +1100
> From: Phill Edwards<philledwards at gmail.com>
> To: Discussion about MythTV<mythtv-users at mythtv.org>
> Subject: Re: [mythtv-users] Mythfrontend irrecoverable recorder error
> Message-ID:
> 	<CAE2RtTOcskq4T8aOKc=mHADuTTCeP+b4yhgMnSANOqWExmV2qA at mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
>
>>> You can try "Delete All Capture cards" then create the new capture cards
>> and connect them to the video source.
>>
> That's what I already did to replace the HDhomerun x4 with the x2 tuner.
> Would I have to rescan the channels?
>
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:<http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240222/1575b3ee/attachment-0001.htm>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums:https://forum.mythtv.org
>
>
> ------------------------------
>
> End of mythtv-users Digest, Vol 251, Issue 26
> *********************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240222/6cf126fb/attachment.htm>


More information about the mythtv-users mailing list