[mythtv-users] Mythfrontend irrecoverable recorder error

Phill Edwards philledwards at gmail.com
Wed Feb 21 22:44:37 UTC 2024


Hi, I recently had to swap out my HDHomerun 4x tuner to a HD Homerun 2x
tuner. I rescanned all the channels and set them up in Channel Editor and
most channels are OK. But when I try to live watch TV Channel 7 or Channel
71 (Sydney, Australia) it pauses and then crashes out back to the menu with
a message saying "Irrecoverable recorder error". I see this in the
myuthbackend.log file:

Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E HDHRStreamHandler
recorders/hdhrstreamhandler.cpp:241 (UpdateFilters) HDHRSH[29](123048B3):
UpdateFilters called in wrong tune mode
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
tv_rec.cpp:3662 (TuningFrequency) TVRec[29]: TuningFrequency
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E TVRecEvent
recorders/hdhrstreamhandler.cpp:484 (TunerSet) HDHRSH[29](123048B3):
DeviceSet(vchannel 5): ERROR: invalid virtual channel
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: E TVRecEvent
tv_rec.cpp:3735 (TuningFrequency) TVRec[29]: Failed to set channel to 71.
Reverting to kState_None
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
tv_rec.cpp:1057 (HandleStateChange) TVRec[29]: Changing from WatchingLiveTV
to None
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: N RecThread
recorders/recorderbase.cpp:490 (FinishRecording) Finished Recording:
Container: MPEG2-TS Video Codec: mpeg2video (720x576 A/R: 3 25fps) Audio
Codec: mp2
Feb 22 09:37:40 MBE4 mythbackend: mythbackend[132205]: I TVRecEvent
tv_rec.cpp:826 (FinishedRecording) TVRec[29]:
FinishedRecording(10091_2024-02-21T22:37:15Z) damaged
recq:<RecordingQuality overall_score="0" key="10091_2024-02-21T22:37:15Z"
continuity_error_count="78" packet_count="34786">#012    <Gap
start="2024-02-21T22:00:00Z" end="2024-02-21T22:37:15Z" duration="2235"
/>#012    <Gap start="2024-02-21T22:37:37Z" end="2024-02-22T00:30:00Z"
duration="6742" />#012</RecordingQuality>
Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I
MythSocketThread(49) mainserver.cpp:7858 (connectionClosed) Playback
sock(555c5f940440) 'MBE4' disconnected
Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I ProcessRequest
mainserver.cpp:1768 (HandleAnnounce) MainServer: MainServer::ANN Playback
Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I ProcessRequest
mainserver.cpp:1770 (HandleAnnounce) MainServer: adding: MBE4(555c5f9078f0)
as a client (events: 0)
Feb 22 09:37:47 MBE4 mythbackend: mythbackend[132205]: I
MythSocketThread(37) mainserver.cpp:7858 (connectionClosed) Playback
sock(555c5f9078f0) 'MBE4' disconnected

I see an error in there "ERROR: invalid virtual channel" but don't
understand why it doesn't like Channel 7 and what I can do to fix it.

BTW I can watch those channels in the HDHomerun mobile app.

Any suggestions?

Regards,
Phill
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240222/8e8dc5b6/attachment.htm>


More information about the mythtv-users mailing list