[mythtv-users] connecting to database failing

James Abernathy jfabernathy at gmail.com
Sun Feb 18 19:51:53 UTC 2024


On Sun, Feb 18, 2024 at 2:34 PM Jay Harbeston <jharbestonus at gmail.com>
wrote:

>
> Yes, I see the four buttons and can search.  It has a pop up that says it
> can't connect to the database.   If I hit escape, I can see my production
> backend and the new local one.  If I select the new local one, it
> eventually times out and says it can't login to the database.
>
> The /etc/mythtv/config.xml is not the same as the
> /home/mythtv/.mythtv/config.xml.  I thought they used to be one file with a
> link at the other location.
>
> my config.xml in the mythtv home directory is
> <Configuration>
>   <Database>
>     <PingHost>1</PingHost>
>     <Host>localhost</Host>
>     <UserName>mythtv</UserName>
>     <Password>6sUFd5O8</Password>
>     <DatabaseName>mythconverg</DatabaseName>
>     <Port>3306</Port>
>   </Database>
>   <WakeOnLAN>
>     <Enabled>0</Enabled>
>     <SQLReconnectWaitTime>0</SQLReconnectWaitTime>
>     <SQLConnectRetry>5</SQLConnectRetry>
>     <Command>echo 'WOLsqlServerCommand not set'</Command>
>   </WakeOnLAN>
>   <UPnP>
>     <UDN>
>       <MediaServer>e909ec1e-cf39-4d31-b9c8-b6418865dfba</MediaServer>
>
> <MasterMediaServer>3963fbcc-6fc9-4bf8-8571-e4fe241b5b20</MasterMediaServer>
>     </UDN>
>   </UPnP>
> </Configuration>
>
> The part in red is the addition not in the /etc/mythtv version of
> config.xml
>
> Also I have noticed that mythutil has issues logging in.
> jim at den-pc:~$ mythutil --scanvideos
> 2024-02-18 14:10:46.034110 C  mythutil version: fixes/34
> [v34.0+fixes.20240218.93a3026e-0ubuntu0] www.mythtv.org
> 2024-02-18 14:10:46.034116 C  Qt version: compile: 5.15.8, runtime: 5.15.8
> 2024-02-18 14:10:46.034136 I  LMDE 6 (faye) (x86_64)
> 2024-02-18 14:10:46.034138 N  Enabled verbose msgs:  general
> 2024-02-18 14:10:46.034143 N  Setting Log Level to LOG_INFO
> 2024-02-18 14:10:46.044896 I  Setup Interrupt handler
> 2024-02-18 14:10:46.044899 I  Setup Terminated handler
> 2024-02-18 14:10:46.044901 I  Setup Segmentation fault handler
> 2024-02-18 14:10:46.044903 I  Setup Aborted handler
> 2024-02-18 14:10:46.044905 I  Setup Floating point exception handler
> 2024-02-18 14:10:46.044907 I  Setup Illegal instruction handler
> 2024-02-18 14:10:46.044908 I  Setup Bus error handler
> 2024-02-18 14:10:46.044917 I  Setup Real-time signal 0 handler
> 2024-02-18 14:10:46.044919 I  Setup Hangup handler
> 2024-02-18 14:10:46.044967 I  Added logging to the console
> 2024-02-18 14:10:46.044983 N  Using runtime prefix = /usr
> 2024-02-18 14:10:46.044984 N  Using configuration directory =
> /home/jim/.mythtv
> 2024-02-18 14:10:46.045089 I  Assumed character encoding: en_US.UTF-8
> 2024-02-18 14:10:46.045303 I  Empty LocalHostName. This is typical.
> 2024-02-18 14:10:46.045310 I  Using a profile name of: 'den-pc' (Usually
> the same as this host's name.)
> 2024-02-18 14:10:46.045412 I  DefaultUPnP() - UPNP Search up to 2 secs
> 2024-02-18 14:10:46.528130 I  DefaultUPnP() - UPNP Search up to 1 secs
> 2024-02-18 14:10:46.879524 I  DefaultUPnP() - UPNP Search up to 1 secs
> 2024-02-18 14:10:48.046161 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 0, status dbAwake, Delay: 2000
> 2024-02-18 14:10:49.047899 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 1, status dbAwake, Delay: 2000
> 2024-02-18 14:10:54.054136 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 2, status dbAwake, Delay: 2000
> 2024-02-18 14:10:59.061115 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 3, status dbAwake, Delay: 2000
> 2024-02-18 14:11:04.068670 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 4, status dbAwake, Delay: 2000
> 2024-02-18 14:11:09.075300 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 5, status dbAwake, Delay: 2000
> 2024-02-18 14:11:14.081584 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 6, status dbAwake, Delay: 2000
> 2024-02-18 14:11:19.088265 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 7, status dbAwake, Delay: 2000
> 2024-02-18 14:11:24.094714 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 8, status dbAwake, Delay: 2000
> 2024-02-18 14:11:29.100907 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 9, status dbAwake, Delay: 2000
> 2024-02-18 14:11:34.107139 I  Start up testing connections. DB
> 192.168.0.101, BE , attempt 10, status dbAwake, Delay: 2000
> 2024-02-18 14:11:39.113309 I  Start up failure. host 192.168.0.101, status
> dbAwakeFail
>
>
> Is there a .mythtv/config.xml in the directory for user Jim? If so, it
> needs to be the same as the config in mythtv/.mythtv/config.xml.
>
> I defer to the true experts of mythtv, but I would imagine the config.xml
> in /etc  is what is getting used by the backend. Sounds like Jim is using a
> diff version.  The webfrontend  backend setup for database will let you
> know for sure which one is getting used.
>
> If it is the /etc version, just link your Jim user config.xml to the /etc/
> one. If not, copy the config.xml from mythtv to etc… and then link the Jim
> as well as mythtv user to the /etc one.
>
> Also add the user Jim to the mythtv group if not there already, and make
> sure /etc/mythtv is owned by mythtv.mythtv
>
> Regards!
>
>
I'll never understand the need for all the different config.xml files but I
just copied /etc/mythtv/config.xml to /home/jim/.mythtv/config.xml and it's
now working. I had previously just deleted the "jim" version in hope it
would be created by the mythfrontend scan and setup process.  I was wrong.

Thanks,

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20240218/0ae7ddfa/attachment.htm>


More information about the mythtv-users mailing list