[mythtv-users] Struggling to build v34 on Opensuse leap 15.4 and 15.5

Paul Gardiner lists at glidos.net
Sun Feb 18 12:14:00 UTC 2024


On 14/02/2024 21:51, James Linder wrote:
> 
> 
>> On Feb 14, 2024, at 21:26, Paul Gardiner <lists at glidos.net> wrote:
>>
>> Thanks James. If I had to guess, I'd say that your mythtv built with python 3.11 must be running without using python3-requests-cache, but given I know little about python, I'll include it as a dependency anyway. Can't hurt, I think.
> 
> This mess is why I shun python as much as possible
> 
> I think the request-cache is used for metadata lookup which *does* work correctly on my system

I ran into some more problems, but I'm now through them and am now 
updated to v34. Thanks again everyone for all the help.

I build my frontend disc image using a system called kiwi-ng and, with 
that, it is difficult to use update repos. Because of the lack of 
updates, I couldn't easily use gcc13, but gcc8 worked. I also had 
problems finding a source for python311-future, but 
https://download.opensuse.org/repositories/devel:/languages:/python:/backports/15.5/ 
has it.  I failed to find a source for python311-requests-cache, but so 
far all seems well without it (metadata download still works at least).

Here are my spec file diffs on the tiny off chance they might help 
someone else: 
https://gitlab.com/glidos-central/package-mythtv/-/commit/07994801c6d9d5346e383431eeb7f87adc67382d

Paul.


More information about the mythtv-users mailing list