[mythtv-users] errors on build of mythtv v34 Debain 12 packages after recent updates

Gary Buhrmaster gary.buhrmaster at gmail.com
Thu Feb 8 21:49:01 UTC 2024


On Thu, Feb 8, 2024 at 9:15 PM David Hampton via mythtv-users
<mythtv-users at mythtv.org> wrote:

> You shouldn't need cmake installed unless you want to test out the new
> build system.  The debian scripts have decided they need to run cmake
> instead of the traditional configure/make.  That's the problem that
> needs to be fixed.

My very limited debhelper knowledge
suggests that the debian build processes
tries to automatically select a buildsystem

It sometimes chooses poorly.

I think one can override that with an
an explicit --buildsystem specification
in the files (possibly --buildsystem=none,
since the mythtv rules has explicit
build instructions when I last skimmed
them).


More information about the mythtv-users mailing list