[mythtv-users] Compiling mythtv-android

James Abernathy jfabernathy at gmail.com
Thu May 11 21:30:54 UTC 2023


On Mon, May 8, 2023 at 2:03 PM Steve Greene <sgreene820 at gmail.com> wrote:

> Hello,
> I'm trying to build mythfrontend-0.33-fixes for android and it appears to
> be barfing on libbluray-1.1.2.
>
>
> I had descended into the libbluray directory and ran the configure script.
> It pointed out that javac was not installed. I installed it from Synaptic
> and compiled from within the folder. Here are the error messages I saw:
>
> compile:
>>     [javac]
>> /home/sgreene/MythAndroid/packaging/android/libs/libbluray-1.1.2/src/libbluray/bdj/build.xml:26:
>> warning: 'includeantruntime' was not set, defaulting to
>> build.sysclasspath=last; set to false for repeatable builds
>>     [javac] Compiling 33 source files to
>> /home/sgreene/MythAndroid/packaging/android/libs/libbluray-1.1.2/src/libbluray/bdj/build
>>     [javac] warning: [options] bootstrap class path not set in
>> conjunction with -source 5
>>     [javac] error: Source option 5 is no longer supported. Use 6 or later.
>>     [javac] error: Target option 1.5 is no longer supported. Use 1.6 or
>> later.
>>
>> BUILD FAILED
>> /home/sgreene/MythAndroid/packaging/android/libs/libbluray-1.1.2/src/libbluray/bdj/build.xml:26:
>> Compile failed; see the compiler error output for details.
>>
>> Total time: 0 seconds
>> make[1]: *** [Makefile:2861: all-local] Error 1
>> make[1]: Leaving directory
>> '/home/sgreene/MythAndroid/packaging/android/libs/libbluray-1.1.2'
>> make: *** [Makefile:1032: all] Error 2
>>
>
> I'm running Linux Mint 21.1 and kernel 5.19.0-41-generic x86_64. Since I'm
> not going to access any blurays from the frontend on Android, can I
> configure it to bypass bluray support? If not, how can I get past this
> error message?
>
> Thanks,
> Steve
>
>
>
> Steve Greene
> (301) 842-8923
> historicity.co
> An independent archival professional specializing in still photography,
> moving images and recorded sound.
>

I just fired up my VM that I use for android builds of mythfrontend. I have
not used it in a while so I did git pulls on both mythtv and packaging.  I
then checked out fixes/33.

libs built fine, but apk failed unrelated to bluray.

I followed the instructions originally to build my environment. from
https://github.com/MythTV/packaging/tree/master/android#readme
I used the exact versions of everything on that page. I've learned not to
change anything.

But I don't know if those instructions are up to date.

If you just want mythfrontend for android 64bit or 32 bit for v33, there
are apks on orangedox
https://dl.orangedox.com/pCBmBm/1EDBdM6bGY2QFwjyi1seMewE3_O_YFfq7

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20230511/5af19754/attachment.htm>


More information about the mythtv-users mailing list