[mythtv-users] mythcommflag hangs: Decoder timed out waiting for free video buffers.

Will Dormann wdormann at gmail.com
Tue May 9 16:48:06 UTC 2023

Hi folks,

Since updating my Ubuntu box and also the MythTV version that comes with 
it to version 31, I've noticed a problem with mythcommflag sometimes not 

The recording in question is one where the schedule is set up to end 
recording early. (i.e. a negative "End Late" value).

Before the upgrade, this worked OK other than some aspects of mythtv 
thinking that the recording was still going on despite it having ended 
early.  I think it was the entry in MythWeb that still showed it as 
recording if memory serves me correctly.

Anyway, now that I've updated things, I've noticed that mythcommflag 
shows as still running in MythWeb without making any progress.  And sure 
enough, there's a mythcommflag process still running for the recording 
in question, without it making any progress.

Looking at the log file, I see entries for the problematic show like:

mythcommflag[1168394]: I CoreContext ClassicCommDetector.cpp:372 (go) 
Finding Logo
mythcommflag[1168394]: I CoreContext ClassicCommDetector.cpp:550 (go) 0% 
Completed @ 133.156 fps.
mythcommflag[1168394]: I CoreContext ClassicCommDetector.cpp:550 (go) 
10% Completed @ 115.144 fps.
mythcommflag[1168394]: I CoreContext ClassicCommDetector.cpp:550 (go) 
20% Completed @ 65.368 fps.
mythcommflag[1168394]: E Decoder mythplayer.cpp:3358 (DecoderGetFrame) 
Player(0): Decoder timed out waiting for free video buffers.

At this point, mythcommflag is completely stuck, never to complete.  If 
I watch the show in MythTV, it shows up as no commercials flagged at all.

Now, if I run mythcomflag (with either the file or the channel + 
starrtime option) manually from a command prompt it goes all the way to 
100%.  Granted it reports an "End of file" error at the end and an exit 
code of 6, but the commercials are successfully flagged, and MythTV 
shows this.

Does anybody know what might be going on here?  Or how I may be able to 
address it in a non-hacky way?

As an aside, now that I'm looking at the mythcommflag logs, I'm seeing 
that it's reporting "VDPAUHelp: VDPAU is NOT available" "VAAPIDec: VAAPI 
functionality checked failed" and "NVDEC: No NVDEC decoders found", 
eventually falling back to ffmpeg.  In the process of configuring 
MythFrontend, I know that at least VDPAU and NVDEC are indeed both 
available, at least to the mythfrontend process.  Is this expected 
behavior?  I'd think that mythcommflag using something other than ffmpeg 
for video decoding would result in better performance, no?


More information about the mythtv-users mailing list