[mythtv-users] mythtv on Fedora 38

John Pilkington johnpilk222 at gmail.com
Mon May 1 14:47:04 UTC 2023

On 01/05/2023 14:58, James Abernathy wrote:
> I'm experimenting with Fedora 38 on a NUC 1165G7 Gen 11 core i7 and 
> wanted to install mythtv.  I first tried the rpmfusion method, but got 
> fatal errors immediately. I also noted that the version was from way 
> back in February.
> I then tried building from source. That seems to work. Ansible playbook 
> worked for all the dependencies.  The configure and build seem to work.
> Can I assume from this that most Fedora users build from source or stay 
> on older versions of Fedora and Mythtv??
> Jim A

I can't speak for others, but for several years I have been running the 
last-but-one version of Fedora and building rpms for MythTV master using 
Gary Buhrmaster's GitHub script.  I prefer to let the Fedora team sort 
out its early OS update bugs first, so that any bugs I do catch are most 
likely to be in a recent Myth commit, and can usually get fixed quickly.

The documented procedures for MythTV DB setup and management in Fedora 
may well be out of date, and the rpms from Gary's script are not quite 
the same as those from rpmfusion.  What I do works, most of the time, 
for me.  I updated to F37 one or two weeks ago.

John P

More information about the mythtv-users mailing list