[mythtv-users] firewall interaction with MythTV

Stephen Worthington stephen_agent at jsw.gen.nz
Tue Dec 5 16:55:31 UTC 2023


On Tue, 5 Dec 2023 08:52:21 -0500, you wrote:

>On Mon, Dec 4, 2023 at 9:09?AM James Abernathy <jfabernathy at gmail.com>
>wrote:
>
>> I have a network issue that I've been avoiding for a while.  I've finally
>> decided to spend some time on it to get it solved.
>>
>> On my Archlinux/EndeavourOS frontend 'firewalld' runs as the network
>> firewall. Once I set the default Zone to Home most things run fine.
>> However, I can't seem to ever get mythfrontend to search to find the
>> backend.
>>
>> What I can do is turn off firewalld, run mythfrontend, and when it fails
>> to connect with the backend have it search for it.  When it finds the
>> backend, it setups up config.xml and everything will continue to work after
>> I turn firewalld back on.
>>
>> There is a service listed in firewalld GUI that is called 'upnp-client'.
>>
>> Would that be the thing I need to allow?
>>
>> Jim A
>>
>>
>I did discover that checking upnp-client has no effect.  However, I do have
>a workaround. Just turning off firewalld during the initial search for the
>backend will allow it to connect.  Once the config.xml is created, you can
>turn firewalld back on and mythfrontend will work from then on.
>
>Jim A

That sounds like firewalld is blocking the broadcast messages used to
find things.  Once there is a config.xml, the connection is direct
without any need for a broadcast message.


More information about the mythtv-users mailing list