[mythtv-users] Firestick 4K installation failing in Fedora

James Abernathy jfabernathy at gmail.com
Fri Sep 30 16:27:32 UTC 2022


On Thu, Sep 29, 2022 at 3:31 PM Peter Bennett <pb.mythtv at gmail.com> wrote:

>
> On 9/28/22 09:54, Peter Bennett wrote:
> >
> > On 9/28/22 06:40, John Pilkington wrote:
> >> Hi:  I haven't been using my Firestick 4K recently because I no
> >> longer have an audio-capable HDMI display, but I wanted to see how it
> >> would work with recordings made by recent master from just one of six
> >> DVB-T muxes.
> >>
> >> In the past I installed the downloaded builds using adb;  this still
> >> worked for leanfront but now fails for the standard frontend.  It
> >> looks as if the Fedora (35) version of android-tools is outdated, and
> >> I haven't yet had success with other suggestions from google.
> >>
> >> {{{
> >>
> >> [john at HPFed Downloads]$ adb install -r
> >> 20220830-leanfront-release-v0-372-g71a3c49.apk
> >> Performing Streamed Install
> >> Success
> >> [john at HPFed Downloads]$ adb install -r
> >> mythfrontend-20220907-arm-v33-Pre-854-gecc24f1e15.apk
> >> Performing Streamed Install
> >> adb: failed to install
> >> mythfrontend-20220907-arm-v33-Pre-854-gecc24f1e15.apk: Failure
> >> [INSTALL_FAILED_OLDER_SDK: Failed parse during installPackageLI:
> >> /data/app/vmdl152075533.tmp/base.apk (at Binary XML file line #8):
> >> Requires newer sdk version #29 (current version is #25)]
> >> [john at HPFed Downloads]$
> >>
> >> }}}
> >>
> >> This is just an FYI.   I'll perhaps try it in kubuntu.
> >>
> >> John P
> >> _______________________________________________
> >>
> > It looks like a problem with the package. The fire stick 4K has API
> > version 25 and it looks like the package is built to require version
> > 29. Perhaps a newer version of QT has caused this change in the build.
> > I will look into it.
> >
> > Peter
> >
> This is now fixed and new 32bit and 64bit packages have been uploaded to
> orangedox
>
> Peter
>

Did you have to do anything special not included on the README.md for
android on github for building master?

I checked out master and build arm64 libs fine, but apk failed.  I can use
orangedox files for now, but wanted to make sure I can build my own if ever
necessary.

partial log below:

make[3]: Entering directory
'/home/jim/workdir/packaging/android/build64/mythtv/external/FFmpeg'
tests/Makefile:245: tests/fate/webm-dash-manifest.mak: No such file or
directory
make[3]: *** No rule to make target 'tests/fate/webm-dash-manifest.mak'.
Stop.
make[3]: Leaving directory
'/home/jim/workdir/packaging/android/build64/mythtv/external/FFmpeg'
make[2]: *** [Makefile:32: FFmpeg-all] Error 2
make[2]: Leaving directory
'/home/jim/workdir/packaging/android/build64/mythtv/external'
make[1]: *** [Makefile:66: external] Error 2
make[1]: Leaving directory
'/home/jim/workdir/packaging/android/build64/mythtv'
make: *** [Makefile:36: apk] Error 2

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20220930/3fbf827a/attachment.htm>


More information about the mythtv-users mailing list