[mythtv-users] Mythfrontend on Android-database access

Stephen Worthington stephen_agent at jsw.gen.nz
Sun May 15 10:43:06 UTC 2022

On Sat, 14 May 2022 23:15:33 -0500, you wrote:

>Just built a new fe/be box with V-32, went OK and is working pretty 
>well.  My PC's video card (GeForce GT 710) is having jitter problems 
>with anything over 720 resolution.  It's may be a little under powered, 
>so I'm trying the frontend alternatives on a Walmart ONN box.
>Leanfront works well; everything worked except one clip that had a 
>server error.  The clip is 4K @ 60fps.  Other 4K clips work fine at 
>lower frame rates, so I assume that's the issue.  Also trying 
>Mythfrontend, but hit a snag.
>When Mythfrontend starts, it shows the startup status display, with 
>"Attempting to connect to Database".  Did a lot of searching but ran out 
>of things to check.  Mythbackend is running (Active: active (running)), 
>PIN is '0000', mysql is listening (bind-address=  Also tried 
>connecting from a ubuntu 18.04 box, with the similar result:
>don at johnny:~$ sudo mysql -umythtv -h192.168.0.184 -p
>Enter password:
>ERROR 1045 (28000): Access denied for user 'mythtv'@'johnny' (using 
>password: YES)
>Sounds like mysql has a permission problem; what should I look for?
>PS - this failed, apparently "IDENTIFIED BY" is deprecated?
>GRANT ALL ON mythconverg.* TO 'mythtv'@'%' IDENTIFIED BY 'mythtv';

Are you running MySQL or MariaDB?  Permissions is an area where they
do differ a little.  And also an area where there have been some
changes.  When messing around with users and permissions, it is best
to use a passwordless root mysql login to ensure you have permissions
to show or grant permissions.

What does this show?

sudo mysql
show grants for 'mythtv'@'%';
show grants for 'mythtv'@'johnny';

The "show grants" command is fairly new - you may not have seen it

If you want to grant all permissions on everything to mythtv@%, and
mythtv@% is already an existing user, then this should work:

grant all on *.* to 'mythtv'@'%' with grant option;

Or if you only want to grant all permissions on the mythconverg

grant all on mythconverg.* to 'mythtv'@'%' with grant option;

I believe that it no longer possible to use "identified by" on a grant
command in order to create a user and grant permissions in the same
command.  You need to create the user as a separate command first:

create user 'mythtv'@'%' identified by '<password>';

More information about the mythtv-users mailing list