[mythtv-users] PCIe DVB-S2 choices

Ken Smith kens at kensnet.org
Fri Jun 24 13:04:43 UTC 2022

Stephen Worthington wrote:
> ** Reply to message from Ken Smith <kens at kensnet.org> on Mon, 20 Jun 2022
> 17:17:04 +0100
>> Stephen Worthington wrote:
>>> On Thu, 16 Jun 2022 13:29:31 +0100, you wrote:
>>>> Short Story: Which PCIe DVB-S2 cards are people having success with?
>>> Both work well for me on Ubuntu 20.04.  They use a custom version of
>>> the Linux DVB media tree:
>>> https://github.com/tbsdtv/linux_media/wiki
>>> You have to compile this against the kernel headers each time the
>>> kernel is updated.
>> After not having much success with the TBS driver about 2 years ago i
>> just tried again using the source from git. It built without a problem
>> on a 5.4 kernel but not on a 5.17 one. (I did have the right header
>> files available each time)
>> Thank you for the suggestion.
>> Ken
> I presume you are using Fedora 36 or similar to get a 5.17 kernel.  I
> just tried compiling on Fedora 36 in VirtualBox and it updated to a 5.18
> kernel and failed to compile with an error about an incompatible pointer
> type:
> /root/projects/tbs6909-drivers/media_build/v4l/msi001.c:504:27: error:
> initialization of 'void (*)(struct spi_device *)' from incompatible
> pointer type 'int (*)(struct spi_device *)'
> [-Werror=incompatible-pointer-types]
>    504 |         .remove         = msi001_remove,
>        |                           ^~~~~~~~~~~~~
> If that is what you are seeing, then it is likely pretty simple to fix by
> changing the pointer declaration or adding a cast.  This sort of error is
> normally only a warning but gcc is flagging it as an error, probably as a
> result of an option it has been given.  So removing that option would
> likely also be a reasonable workaround.  It is also possible that the
> option now defaults to on as gcc is version 12, where it is still version
> 11 on Ubuntu 22.04 where it does compile correctly.  In any case, I have
> posted an issue about the problem:
> https://github.com/tbsdtv/linux_media/issues/286
That's the same error I got on 5.17. I have a RHEL 8 clone system where 
I have loaded both the 5.4 and 5.17 kernels from the elrepo repository. 
gcc is version 8.5 on that system.

On the off chance that the TBS media tree has some patches that have a 
bearing on the problem I've been chasing with the HVR-5525 capture card 
(for example changes to the cx23885 driver) I've been running the 
HVR-5525 with the TBS's DVB media tree. Sadly I get the same behaviour 
with the TBS tree - but it was worth a test.

:-) Ken



This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the mythtv-users mailing list