[mythtv-users] mythtv-setup without UPNP searching for backend?

Jim Abernathy jfabernathy at gmail.com
Wed Jan 12 11:08:12 UTC 2022


On 1/11/22 8:55 PM, Paul Harrison wrote:
>
> What I do is create a new devicemaster.xml so I can tell which backend 
> is which.
>
> Some basic instructions here on the UPnP page in the wiki "Overriding 
> the default devicemaster.xml file" section.
>
> https://www.mythtv.org/wiki/UPnP#Overriding_the_default_devicemaster.xml_file
>
>
> Paul H.
>

Paul,

This is what I'm looking for, Thanks. However, I must had implemented it 
wrong. I think I have the devicemaster.xml setup right, but the sql 
command must be wrong for my setup.

Here's the diff between the official devicemaster.xml and mine:

diff -Naur /usr/share/mythtv/devicemaster.xml 
/home/mythtv/.mythtv/devicemaster.xml
--- /usr/share/mythtv/devicemaster.xml    2021-11-08 18:25:26.000000000 
-0500
+++ /home/mythtv/.mythtv/devicemaster.xml    2022-01-12 
05:45:25.284823621 -0500
@@ -6,13 +6,13 @@
      </specVersion>
      <device>
          <!-- UDN auto generated -->
-        <friendlyName>MythTV AV Media Server</friendlyName>
+        <friendlyName>MythTV Production Backend</friendlyName>
<deviceType>urn:schemas-upnp-org:device:MediaServer:4</deviceType>
          <manufacturer>MythTV</manufacturer>
<manufacturerURL>http://www.mythtv.org/</manufacturerURL>
-        <modelName>MythTV AV Media Server</modelName>
+        <modelName>MythTV Production Backend</modelName>
          <!-- uncomment to override defaults 
<modelNumber>0.20</modelNumber> -->
-        <modelDescription>MythTV AV Media Server</modelDescription>
+        <modelDescription>MythTV Production Backend</modelDescription>
          <modelURL>http://www.mythtv.org/</modelURL>
          <presentationURL>/</presentationURL>
          <dlna:X_DLNADOC 
xmlns:dlna="urn:schemas-dlna-org:device-1-0">DMS-1.51</dlna:X_DLNADOC>
@@ -21,13 +21,13 @@
          <deviceList>
              <device>
              <!-- UDN auto generated -->
-            <friendlyName>MythTV Master Media Server</friendlyName>
+            <friendlyName>MythTV Production Backend</friendlyName>
<deviceType>urn:schemas-mythtv-org:device:MasterMediaServer:1</deviceType>
              <manufacturer>MythTV</manufacturer>
<manufacturerURL>http://www.mythtv.org/</manufacturerURL>
-            <modelName>MythTV Master Media Server</modelName>
+            <modelName>MythTV Production Backend</modelName>
              <!-- uncomment to override defaults 
<modelNumber>0.20</modelNumber> -->
-            <modelDescription>MythTV AV Media Server</modelDescription>
+            <modelDescription>MythTV Production Backend</modelDescription>
<modelURL>http://www.mythtv.org/</modelURL>
              <presentationURL>/</presentationURL>
              <!-- uncomment to override defaults 
<serialNumber>MYTHTV-UPNP-01</serialNumber> -->

Not knowing any better, I did the mysql commands exactly as listed.  
Maybe I should have changed the syntax???

INSERT INTO settings (value, data, hostname) VALUES ('upnpDescXmlPath', 
'/home/mythtv/.mythtv/', 'HOSTNAME');

What should 'HOSTNAME' have been???

Jim A




More information about the mythtv-users mailing list