[mythtv-users] building android mythfrontend on Ubuntu 22.04 vs. 20.04?

James Abernathy jfabernathy at gmail.com
Fri Aug 19 12:55:23 UTC 2022

On Fri, Aug 19, 2022 at 4:10 AM John <jksjdevelop at gmail.com> wrote:

> On 18/08/2022 21:11, James Abernathy wrote:
> On Thu, Aug 18, 2022 at 3:57 PM Peter Bennett <pb.mythtv at gmail.com> wrote:
>> On 8/17/22 16:15, James Abernathy wrote:
>> > So I was testing out the updated Readme.md at
>> > https://github.com/MythTV/packaging/tree/master/android
>> > by building a KVM VM using Ubuntu 20.04 and the instructions including
>> > the dependencies worked as documented. So I thought I'd see if this
>> > held true on Ubuntu 22.04. Well it did not.  After I built the VM
>> > using Ubuntu 22.04 I followed the Readme.md again and it failed
>> > building the libs and the error seemed to indicate it could not find
>> > the command 'pkg-config'.
>> >
>> > I checked the 20.04 VM and it had the command pkg-config but 22.04
>> > didn't.  I did sudo apt install pkg-config on the 22.04 VM and then
>> > the libs were built.  However, when I tried to build the apk, I got an
>> > error about not finding 'libmariadb.so'.
>> >
>> > This made no sense to me.  Anyone have any ideas? Obviously, I could
>> > update the Readme.md to say Ubuntu 20.04 only, but that would seem odd.
>> >
>> > Jim A
>> >
>> >
>> > _______________________________________________
>> I have built on 22.04 ever since I upgraded to 22.04 a couple of months
>> ago. I have not had any problems, although I did build the libs on 20.04
>> and continued using the same ones on 22.04. Are you building fixes/32 or
>> master?
>> Peter
> I think there must be something different about having 20.04 working and
> then upgrading in place to 22.04.  I may do an experiment if I have time.
> I'm doing fixes/32 only when testing 22.04.
> After I had 20.04 production arm and arm64 apks for fixes/32, I did try
> master just to see since I have a master FE/BE combo testing system working
> fine on Master, but while libs built, apks failed hard and early.  I didn't
> even try to figure out what was missing.
> Both the 20.04 and 22.04 android builder systems were just VMs so they
> were fresh systems with just what it took to run the android builds.  My
> new Readme.md was strictly 20.04, fresh VM  and it's repeatable.  Since I
> can build a 20.04 VM as easily as 22.04, I really don't care, but someone
> will try 22.04 naturally and it will fail. If I could identify the problem
> that would be good to note the changes, but otherwise I may want a 20.04
> only warning in the readme.
> Jim A
> Just to confirm the above from Jim. On Ubuntu 22.04 the build for the
> libraries on Myth 32 completes without errors but mariadb has not been
> compiled.

Along these lines. I started fresh this morning with a new 20.04 Ubuntu VM
and followed the Readmd.md and had no issues with the arm 32 bit build of
android mythfrontend v32 with a release key I created.

Then I repeated the steps for 64 bits, first the libs, and then the apk.
The libs did fine, but on the apk I got an error in the signing process
where it could not find a tool it needed, zipalign. The odd thing is it was
saying it could not find it in Android/Sdk/build-tools/29.0.2/.  This is
obviously because that directory doesn't exist because I installed sdk
build-tools 29.0.3. There is most likely a place in the mythfrontend
building scripts for 64 bits where the need for build-tools 29 is looking
for 29.0.2 instead of 29.0.3 which I installed. I looked around in those
scripts and saw some variables that specified 29, but no extension beyond

Jim A
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20220819/0825299b/attachment.htm>

More information about the mythtv-users mailing list