[mythtv-users] Can't connect to remote backend database (again)

Mike Perkins mikep at randomtraveller.org.uk
Sun Sep 12 09:23:34 UTC 2021


On 12/09/2021 08:48, Phill Edwards wrote:
>>
>>
>>
>>> Thanks Stephen. I tried what you suggested and changed the MySQL settings
>>> but the Chomecast with Google TV still wouldn't connect. So I dropped the
>>> user account in MySQL and re-created it. Still no joy - even though the PC
>>> sitting right next to it on the same subnet connects without problems.
>>>
>>> I also contacted the developer of the mythtvfrontend Android app and
>>> relayed your theory to him. He was very helpful and tried installing and
>>> connecting and it all worked fine for him. After his testing he said "So
>> it
>>> is not an incompatibility with mysql or with recent versions that is
>>> causing the problem".
>>>
>>> I've also tried to install a MySQL client on the device. But there's only
>>> one I could find, and it doesn't work on Google TV because the UI won't
>> let
>>> you create a connection database using a remote control. The developer is
>>> going to address that in the next release but I have no idea when that
>> will
>>> be.
>>>
>>> So I'm now even more stumped than I was before.
>>
>> If you capture the TCP/IP packets again, is it the same as before - is
>> it still the same error message?
>>
> 
> Thanks very much, Stephen, for your patient assistance with this one. I
> didn't try your last suggestion. But I have fixed the problem. When I
> disconnected  the wired ethernet connection and connected with WiFi
> instead,Mythfrontend connected without any issues. Obviously I'm delighted
> with this development. But I have no idea why it can connect over WiFi but
> not ethernet when they're on the same subnet. It doesn't make sense to me.
> Do you think there could be a bug of some sort with the devices' ethernet
> implementation? The ethernet cable connects into the power supply which is
> an adaptor sold by Google -
> https://store.google.com/au/product/chromecast_ethernet_adapter_gen_2?hl=en-GB
> 
> It's good news that it's working. But the WiFi connection obviously isn't
> as fast as the ethernet connection, so I would like to get it going over
> ethernet eventually if I can. I might try a powered USB hub and connect the
> ethernet to that instead of the power supply and see if that works. i did
> have one but I've lost it!
> 
It is possible that you are misunderstanding the function of the device you link to. (It is also 
possible that I am misunderstanding it!)

 From my reading of the very sketchy description, this device is designed for locations where a WiFi 
signal is poor or non-existent. Therefore, I would think that all it has is a mini-WiFi access point 
from which the Chromecast can get a local signal.

It won't be sending Ethernet up the power cable, if that's what you assumed.

-- 

Mike Perkins



More information about the mythtv-users mailing list