[mythtv-users] Issue with back end host address

Stephen Worthington stephen_agent at jsw.gen.nz
Tue Jun 15 18:09:10 UTC 2021

On Tue, 15 Jun 2021 11:38:51 -0500, you wrote:

>I had disabled IPv6 because my LAN router isn't configured to support 
>IPv6 (for instance, no DHCPv6 server) and I'd seen some services (e.g., 
>iSCSI) experience issues due to trying to use IPv6. When I had IPv6 
>enabled at the kernel level, I had disabled IPv6 on my PC's Ethernet 
>interface yet an IPv6 IP was still assigned to it. It didn't seem right 
>to have services trying to use IPv6 when I have done nothing to make 
>IPv6 work on my LAN.
>Now Google turns up some forum posts that suggest that MythTV >= 0.26 
>can have issues when IPv6 is disabled.
>So what am I to do? Turn IPv6 back on at the kernel and deal with any 
>IPv6-related service issues as they crop up? Please advise...

Having local IPv6 working is usually OK if no global unicast IPv6
addresses are assigned.  Since your router does not do IPv6, it should
not be sending any IPv6 Router Advertisement packets, so with IPv6
enabled, your interfaces should only get link-local IPv6 addresses -
which they may be able to use to talk to each other on the same
subnet, but should not cause any problems.  Windows and Linux boxes
these days all have IPv6 enabled, but if the routers do not do IPv6,
they mostly work just fine without having to disable IPv6.

However, just to be safe, you would want to make sure that your DNS
server(s) did not provide any IPv6 addresses for things.  I run ISC
Bind 9 for my DNS servers, and on a special test subnet where IPv6 is
enabled and global unicast IPv6 addresses are assigned, but there is
no working routing to the wider Internet via IPv6, I had a similar
problem, where connections to the Internet frequently failed when they
tried to use IPv6, and if they eventually switched to IPv4 and got a
connection, it took a while and slowed everything down.  So I just
configured bind 9 to temporarily only report IPv4 addresses, until I
can fix the IPv6 routing problem.  To do that in the latest versions
of bind 9 you have to do two things:

1) Stop bind from listening on IPv6 addresses.  Just comment out any
"listen-on-v6" options.

2) Stop bind from returning AAAA addresses.  The web pages I found for
this were out of date.  They say to just add an option
"filter-aaaa-on-v4 yes;".  But in recent bind 9 versions (from 9.13
on), that filter capability has been moved to a plugin library, so you
need to do this instead:

plugin query "filter-aaaa.so" {
  filter-aaaa-on-v4 yes;

If you are using multiple views in bind 9 as I am, then those lines go
inside the config for each view they apply to.  The filter-aaaa.so
library file is part of the main bind9 package on Ubuntu, so it should
already be installed.

More information about the mythtv-users mailing list