[mythtv-users] Important: Changes to Metadata lookup in March 2021

Jay Foster jayf0ster at roadrunner.com
Sat Feb 27 21:18:42 UTC 2021

On 2/26/21 6:18 AM, Peter Bennett wrote:
> On 2/25/21 4:22 PM, Hika van den Hoven wrote:
>> I have tested the integration with mythtv and that works. Even beter
>> than I had expected!
>> I thought it possible that mythmetadatalookup would simply use the
>> script name in the inetref, but I thought first to test what would
>> happen if I renamed tvmaze.py to ttvdb.py and it worked. So good that
>> the inetref was after the hit changed to reflect tvmaze.py.
>> However, if you do not copy either tvmaze.py or tmdb3tv.py to ttvdb.py
>> searches won't work, it will always come up with a tmdb3.py reference.
>> So choose which of the two you want and copy (or simlink) that one to
>> ttvdb.py.
> Hi Hika
> Can you explain this. I don't understand.
> All you need to do is go into mythfrontend -> setup -> Artwork and 
> Data Sources -> Television Metadata Source
> Change there to whichever script you want and it will use that script 
> for shows that do not have the inetref filled in.
> If you link one of the other script names to ttvdb.py then those 
> recording rules and recorded shows that have ttvdb.py_nnnnn in the 
> inetref will lookup the wrong show because the nnnnn is different for 
> each of the sources.
> Maybe this works differently in 0.27. Does 0.27 have the Artwork and 
> Data Sources entry?
> Peter
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://lists.mythtv.org/mailman/listinfo/mythtv-users
> http://wiki.mythtv.org/Mailing_List_etiquette
> MythTV Forums: https://forum.mythtv.org

This is not working for me with 0.28.  I go to mythfrontend -> setup -> 
Artwork and Data Source -> Television, but there is only one choice 
there (TheTVDB.com).  This is the name when using the previous tvdb.py 
script.  Is it also the correct name for the new tvdb3tv.py script?  And 
why do I not see tvmaze as a choice? I tried restarting the backend and 
frontend, but makes no difference.


More information about the mythtv-users mailing list