[mythtv-users] Fwd: backend (?) crash

Klaas de Waal klaas.de.waal at gmail.com
Sat Feb 20 09:13:50 UTC 2021


On Sat, 20 Feb 2021 at 00:08, Klaas de Waal <klaas.de.waal at gmail.com> wrote:

> Your frontend log shows that it cannot connect to the backend, otherwise
> it is OK.
> Your backend log fragment shows that it wants to create a new virtual
> tuner for a multirec recording but that this fails. This should not happen.
> To get to the bottom of this a lot more information would be needed, such
> a complete backend log and a dump of some database tables.
> You can create a Github issue and then you can attach bigger log files
> than you can with the mailing list.
>
> For the time being I suggest to:
> - check that your database is correct by running optimize_mythdb.pl
> - run the latest updated version, e.g. v31/fixes
>
> You can also with mythtv-setup:
> - delete all capture cards
> - create new capture cards
> - connect them to the video source
>
Reason is that your backend issue could be caused by a corrupt capturecard
> table.
>

If the error is related to a capture card that does convert external video
signals such as a HD-PVR then it can be a configuration issue.
In mythtv-setup look at page Input Connections / Interaction between Inputs
For a HD-PVR the "Max Recordings" should be 1 and the  "Schedule as Group"
should be unchecked.

When the  "Schedule as Group" is checked then additional virtual tuners are
created when needed, but this can only work when the complete transport
stream is available such as with capture cards that have a tuner.

Klaas.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-users/attachments/20210220/5c6abbf0/attachment.htm>


More information about the mythtv-users mailing list