[mythtv-users] mac build

James Linder jam at tigger.ws
Sun Feb 7 13:01:22 UTC 2021

> On 7 Feb 2021, at 8:33 pm, James Linder <jam at tigger.ws> wrote:
>> On 7 Feb 2021, at 1:31 pm, James Linder <jam at tigger.ws> wrote:
>>> On 6 Feb 2021, at 11:08 pm, John Pilkington <johnpilk222 at gmail.com> wrote:
>>> On 06/02/2021 14:58, John Hoyt wrote:
>>>>> I just grabbed
>>>>> 1aff6fd2db
>>>>> but I guess I ought to wait for Mark. So when he commit I
>>>>  download or build which ever is easier
>>>> James, I'll post fresh builds for High Sierra, Catalina, and Big Sur once the updates get backported to v31.
>>>>  After Mark's commit "AudioOutputGraph: Fix buffer overflow"
>>>>  yesterday at
>>>>  0c76409, for the first time, returning to an edit point regenerates the
>>>>  same audio graph.  I look forward to the further cleanup and have
>>>>  scheduled a recording of the time signal  :-)
>>>> Glad to hear Mark's fix seems to be working.
>>> Unfortunately it's still not repeatable in that radio recording, but progress all the same.
>> John I don't think it's your ansible setup, I'll spelunk and also I'll build a version I've built in the past
>> . . .
>> clang -F/opt/local/libexec/qt5/lib -o obj/audiooutput.o audio/audiooutput.cpp
>> ccache clang++ -c -pipe -stdlib=libc++ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DPIC -I /Users/jam/mythtv-31/mythtv/mythtv/external -I /opt/local/include -std=c++11 -DNDEBUG -fomit-frame-pointer -fPIC -DQT_DISABLE_DEPRECATED_BEFORE=0x050700 -msse -pthread -g -Wall -Wextra -Wpointer-arith -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -Wno-constant-logical-operand -Wno-unused-value -Qunused-arguments -Wimplicit-fallthrough -std=gnu++11  -arch x86_64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk -mmacosx-version-min=10.13 -fPIC -DMMX -DUSING_APPLEREMOTE -D_GNU_SOURCE -DMYTH_API -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SQL_LIB -DQT_SCRIPT_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I. -I/opt/local/include/libxml2 -I../../external/libmythsoundtouch -I../libmythfreesurround -I../libmythbase -I../.. -I.. -I. -I../libmythupnp -I../libmythui -I../.. -I../../external/FFmpeg -I../libmythservicecontr
> ac
>> ts -I/opt/local/libexec/qt5/lib/QtWidgets.framework/Headers -I/opt/local/libexec/qt5/lib/QtGui.framework/Headers -I/opt/local/libexec/qt5/lib/QtNetwork.framework/Headers -I/opt/local/libexec/qt5/lib/QtXml.framework/Headers -I/opt/local/libexec/qt5/lib/QtSql.framework/Headers -I/opt/local/libexec/qt5/lib/QtScript.framework/Headers -I/opt/local/libexec/qt5/lib/QtDBus.framework/Headers -I/opt/local/libexec/qt5/lib/QtCore.framework/Headers -Imoc -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/System/Library/Frameworks/OpenGL.framework/Headers -I/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk/System/Library/Frameworks/AGL.framework/Headers -I/opt/local/libexec/qt5/mkspecs/macx-clang -F/opt/local/libexec/qt5/lib -o obj/audiooutputbase.o audio/audiooutputbase.cpp
>> audio/audiooutputbase.cpp:630:18: error: use of undeclared identifier 'ff_codec_id_string'
>>           .arg(ff_codec_id_string(m_codec))
>>                ^
>> 1 error generated.
>> make[2]: *** [obj/audiooutputbase.o] Error 1
> To err is human
> To really muck things up you need a computer
> I'm using parallels as a VM and it does not like more than 2 cores. Since 6 cores is LOTS quicker I built native, not in a VM.
> I tried to build 102dbe673325fccbc5bf073f94e4 in the past and it worked, but now that fails too so clearly my setup and most likely my mackports is causing a problem.
> I ran my fe normally to watch the news
> /Applications/Mythfrontend.app/Contents/MacOS/mythfrontend
> dyld: Library not loaded: /opt/local/lib/libjpeg.9.dylib
>  Referenced from: /Applications/Mythfrontend.app/Contents/Frameworks/QtWebKit.framework/Versions/5/QtWebKit
>  Reason: image not found
> /Applications/Mythfrontend.app/Contents/MacOS/mythfrontend: line 15:   401 Abort trap: 6           ./mythfrontend.real $@
> I'll like my wounds, and re-install macos, but the bundle reffering to a macports dylib looks wrong.

When Jack got out of the bottomless pit ...
[plasma] /Users/jam/mythtv-31/mythtv [550]% /Applications/Mythfrontend.app/Contents/MacOS/mythfrontend --version
dyld: Library not loaded: /opt/local/lib/libjpeg.9.dylib
  Referenced from: /Applications/Mythfrontend.app/Contents/Frameworks/QtWebKit.framework/Versions/5/QtWebKit
  Reason: image not found
/Applications/Mythfrontend.app/Contents/MacOS/mythfrontend: line 15:   503 Abort trap: 6           ./mythfrontend.real $@

but I'm sure it was 1aff6fd2db

Sorry about the spelling . . . typing in bed lick not like, macports not mackports :-)
I'll try remove-reinstall macports then bite the bullet. (Gee that sounds like the typical windows fix - reinstall (and yes it is not the same))

More information about the mythtv-users mailing list