[mythtv-users] Performance of the Video Gallery

Jan Ceuleers jan.ceuleers at gmail.com
Mon Dec 13 18:36:35 UTC 2021


Dear fellow MythTV users,

The mythweb discussion prompted me to take another look at the web
frontend (i.e. http://<backend>:6544), and I noticed that the Video
Gallery takes a very long time to load on my system (~60s).

My video storage group is spread across four disks, which are SSDs, and
they contain 4567 files across a hierarchy of a total of 516 directories.

When I then navigate deeper into the hierarchy performance gets a lot
snappier.

While waiting for the top-level Video Gallery to open one mythbackend
thread is busy full-time. The backend hass a 4GHz i3-8350K with 32GB
RAM. MythTV version below. Ubuntu 20.04.

I don't mean this to be a criticism, but I was wondering whether there
is something I can do to improve this. Should I file a bug? Is there any
diagnostic information I should collect?

Many thanks, Jan



MythTV Version : v31.0+fixes.202111081900.25f1bb1d12~ubuntu20.04.1
MythTV Branch : fixes/31
Network Protocol : 91
Library API : 31.20200101-1
QT Version : 5.12.8
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse
using_pulseoutput using_backend using_bindings_perl
using_bindings_python using_bindings_php using_dvb using_firewire
using_frontend using_hdhomerun using_vbox using_ceton using_hdpvr
using_ivtv using_joystick_menu using_libcec using_libcrypto using_gnutls
using_libdns_sd using_libfftw3 using_libxml2 using_lirc using_mheg
using_opengl using_egl using_qtwebkit using_qtscript using_qtdbus
using_taglib using_v4l2 using_x11 using_libbluray_external using_xrandr
using_profiletype using_systemd_notify using_systemd_journal
using_bindings_perl using_bindings_python using_bindings_php
using_freetype2 using_mythtranscode using_opengl using_egl using_vaapi
using_nvdec using_vdpau using_ffmpeg_threads using_mheg using_libass
using_libxml2 using_libmp3lame


More information about the mythtv-users mailing list