[mythtv-users] Can't connect to remote backend database (again)

John Pilkington johnpilk222 at gmail.com
Sat Aug 7 10:03:19 UTC 2021

On 07/08/2021 06:14, Phill Edwards wrote:
>         Thank you for these suggestions. I've got lots of PCs and
>         virtual machines around the place so I can have a crack at this.
>         I'm pretty sure it's not an issue with the MythBackend server
>         config, or the subnet because I have a linux PC on the same
>         subnet running MythFrontend which works fine. Inspired by your
>         suggestions I think I'll reconfigure a linux frontend to have
>         the same IP address as the Chromecast device and see if it can
>         connect. That should give me some pointers. 
> Well, this is getting "interesting" (i.e. even more frustrating!). I set 
> a linux frontend to have the IP address that the Chromecast With Google 
> TV was using ( And I had already set a different password 
> in MySQL for mythtv at <mailto:mythtv at>. The 
> linux frontend connects without any problems. The Chromecast With Google 
> TV can't connect. That makes no sense to me.
> So then I managed to install an SSHD app (SSHelper which has to be 
> sideloaded from https://arachnoid.com/android/SSHelper/ 
> <https://arachnoid.com/android/SSHelper/>) on the Chromecast With Google 
> TV.
> Now, if I run this command on my PC the connection succeeds:
> C:\Users\phill>telnet 3306
> But if I SSH into the Chromecast With Google TV and run it, it fails as 
> follows:
> $ telnet 3306
> kHost '' is blocked because of many connection errors; 
> unblock with 'mysqladmin flush-hosts'Connection closed by foreign host
> I believe this indicates that MySQL on the MythBackend has permanently 
> blocked the Chromecast With Google TV due to previously failed 
> connection attempts. So I logged into MySQL as root and ran:
> mysql> flush hosts;
> I can now telnet 3306.
> But it hasn't fixed the problem. MythFrontend on the Chromecast With 
> Google TV still can't connect. I've cleared the cache, cleared the data 
> and re-entered the username and password. I've created a new 
> account called mythtv2 and tried to connect with that, but that doesn't 
> work either.
> I noticed that even after clearing the MythFrontend app data on 
> Chromecast With Google TV, when I restart the app it still displays 
> mythtv as the user and an old password. This also happened after 
> uninstalling and re-installing the app. Where could it be getting thi
> from, and could it indicate a problem that may be behind all this?

Earlier this year I had similar mysterious and persistent attempts to 
connect to the wrong backend.  I was running master.

Somehow the UPnP section of ~/.mythtv/config.xml had acquired nested 
Mythfrontend, DefaultBackend, USN entries.  Resetting the host address 
worked again after those lines had been commented out. ( <!--   --> )

John P

More information about the mythtv-users mailing list